3D Design

3D Design

Topics related to Ansys Discovery and Ansys SpaceClaim.

Starting Spaceclaim by clicking on a .scdoc file

TAGGED: ,

    • rautertj
      Subscriber

      Dear support team,

      I struggle with an issue, which normally is easy to solve: I´d like to click on a Spaceclaim „file.scdoc“ to start Spaceclaim with the respective file.

      One common way to do so is, to associate the file using the „open with“ feature in Windows and direct the explorer to the .exe of the program.  Often programs also ask, if they should associate with certain file extensions.

       

      I tried with Spaceclaim, and directed to the respective path during the „open with“ dialogue. The program starts, but then comes up with a warning:

      "Failover feature ´Discovery level 1´is not available. Novalid FLEXlm servers specified"        

      If you continue, it offers to start in readonly mode as a viewer, because it can´t find the licensing file.

      "No valid licensing file found. How do you want to proceed?  Write proteceted mode or cancel"

      I´m a named user and my copy is registered and works perfect, as long as I start the program first and then open file from it or drag file onto it.

       

      Any idea, what to do?

    • Subashni Ravichandran
      Forum Moderator

      Hello Jurgen Rautert

      Let me check this from my end and get back to you.

    • Subashni Ravichandran
      Forum Moderator

      Hello Jurgen Rautert

      Can you please share the screenshot of the image?

      • rautertj
        Subscriber

        Subashni 


      • ERab
        Forum Moderator

        Jurgen Rautert Did you happen to install the Ansys License Manager?  If yes, try uninstalling it.

      • rautertj
        Subscriber

        Ethan Rabinowitz Hi Ethan, no, I was told not to do so and I didn´t.  Yesterday I made another observation: Even when Spaceclaim is opened already, double-clicking a file leads to the same result shown in the pics above. If I drag and drop the file onto the already open program, it works however. It´s not a big nuisance, just strange. Could it be, that I have to direct to another executable file in the "open with" dialogue of the explorer?

    • Subashni Ravichandran
      Forum Moderator

      Jurgen Rautert

      Thanks for the update. Ethan and I are checking with my team for more information on this issue.

      We believe it has something to do with the registry command for SpaceClaim Named user license.

      I will get back to you soon with more information. 

    • rautertj
      Subscriber

      If you´d like to make a remote session to check on my computer, I´m available and flexible timewise.

      • Subashni Ravichandran
        Forum Moderator

        Jurgen Rautert 
        I checked with the development team and this error usually appears when the program is launched without the command /UseSubscription=true.

        When a program is set as the default to open a particular file type, an entry is added to the Windows registry.  
        That entry points to the executable (spaceclaim.exe for example) but does not include additional commands.

        Look for the registry key ComputerHKEY_CLASSES_ROOTstp_auto_fileshellopencommand

        Modify the value to the following:

        "C:Program FilesANSYS Incv221scdmspaceclaim.exe" "%1" "USERUNNINGSPACECLAIM=true" /UseLicenseMode=true

         

        Let me know if this works

      • jn.rt
        Subscriber

        Subashni Hi, thanks for following up the issue. Tried your proposal but unfortunately with no other results than before, see screenshots.



    • Subashni Ravichandran
      Forum Moderator

      Hello Jürgen Rautert

      I'm not sure what else we can try here, except a clean install. Let me know if that works. 

      If not I can check with the development team again.

      Make sure to delete the %temp% and C:\Users\username\AppData\LocalAnsys_Inc before reinstall

Viewing 5 reply threads
  • The topic ‘Starting Spaceclaim by clicking on a .scdoc file’ is closed to new replies.