LS Dyna

LS Dyna

Topics relate to LS-DYNA, Autodyn, Explicit STR and more

Negative Volume

TAGGED: 

    • Mehdi Saloo
      Subscriber

      Hello,

      I have modeled a timber panel in LS-DYNA using *MAT_WOOD. The analysis goes well until a negative volume error terminates the analysis.  

      I found some information and approaches that can help to overcome negative volumes in the following link:

      https://www.dynasupport.com/howtos/material/negative-volume-in-soft-materials

      In materials that undergo extremely large deformations, such as soft foams, an element may become so distorted that the volume of the element is calculated as negative. This may occur without the material reaching a failure criterion. There is an inherent limit to how much deformation a Lagrangian mesh can accommodate without some sort of mesh smoothing or remeshing taking place. A negative volume calculation in LS-DYNA will cause the calculation to terminate unless ERODE in *CONTROL_TIMESTEP is set to 1 and DTMIN in *CONTROL_TERMINATION is set to any nonzero value in which case the offending element is deleted and the calculation continues (in most cases). Even with ERODE and DTMIN set as described, a negative volume may cause an error termination.

      I followed the approaches and set the ERODE=1 and DTMIN= nonzero, however, I understood that the analysis is very sensitive to the value of DTMIN which is a reduction factor for initial time step size to determine minimum time step. When I set it as a number equal to or greater than 1, all elements will be deleted at the beginning of the analysis. When I set it as a value between zero and 0.1 (e.g. DTMIN=0.08), all elements will be deleted at some point at the middle of the analysis. It is also noteworthy that when I set it as a number between 0.1 and one (e.g. DTMIN=0.8), error termination occurs because of out of range velocity of some nodes.

      Therefore, I wonder how I can find the proper value for DTMIN so that I can get rid of such a negative volume error. I would appreciate it if you could give me some advice in this regard or any other approaches that can help to overcome negative volumes for my model.

      Thanks in advance.

      Regards,

      Mehdi

    • Jim Day
      Ansys Employee
      Setting ERODE to 1 and DTMIN to a value less than 1.0 will not have a direct effect on the solution time step. Its purpose is to delete solid elements that would otherwise stop the calculation due to negative volume and also delete solid elements whose current time step drops below the threshold of dtstart*DTMIN. Try ERODE=1 and DTMIN=0.5. If all the elements erode at some point during the simulation, it means all those elements have met at least one of the two criteria mentioned above.
    • Jim Day
      Ansys Employee
      You might have a more stable simulation if you reduce the time step scale factor TSSFAC in *CONTROL_TIMESTEP. What solid element formulation are you using (ELFORM in *SECTION_SOLID) and what is the hourglass control type and hourglass coefficient?
      • Mehdi Saloo
        Subscriber

        Hello Jim,

         

        Thanks ever so much for your help, I really appreciate it.

        I set ERODE=1 and DTMIN=0.5 at your suggestion. I am also using TSSFAC=0.67 and ELFORM=1 for my model. When I run the model with such settings, element erosion will happen due to negative volume as you can see in the following pictures. However, the message file says 195 elements eroded but LS-PrePost shows only 2 elements eroded in the red ply! I wonder what the reason for this difference is!

         

        By the way, this time, error termination occurs again because of the out-of-range velocities of some nodes. Please see the following picture.

        Regarding the hourglass control, I do not use this option so far. I know that there are two methods to use this option, *Control_Hourglass and *Hourglass. I do not know which one I should use for my model. I also wonder which hourglass control type and hourglass coefficient are proper for my model.

         

        Thanks in advance for your kind attention.

        I look forward to hearing from you.

        Regards,

        Mehdi

    • Jim Day
      Ansys Employee

      Hi, Mehdi. The time of the plot state in d3plot that you’re looking at precedes the time reported in the Warning message. I assume that’s the reason you don’t see evidence of all the deleted elements in the view of the geometry.

      Make another run with the hourglass type set to 4 and the hourglass coefficient set to 0.03 (for the timber). If you still get rampant element deletion, it would then be prudent to scrutinize your input for the *MAT.

Viewing 3 reply threads
  • The topic ‘Negative Volume’ is closed to new replies.