Ansys Free Student Software

Ansys Free Student Software

Topics cover installation and configuration of our free student products

Mesh Size Limit

    • Angel Tovar Martinez
      Subscriber

      Hi! This is my first post in a forum in quite some time. My problem is as follows:
      I'm trying to model a PMSM (Permanent Magnet Synchronous Machine). I used RMxprt to create the motor and after validating and analysing it I created a 2D Maxwell design. Because Student Version doesn't support transient solutions, I changed it into Magnetostatic solution type. After doing the analysis setup, I ran the validation check and all was good. Then I ran de "analyze all" section and the mistake that popped is "Setup1: Mesh size (2412 surface elements) exceeded Ansys Electronics Desktop Student limit."
      Because this problem seemed pretty obvious, I tried reducing the mesh size, but with no effective result regardless.

      I asked ANSYS support if they knew what the limit regarding mesh size is but I was redirected here. Does anybody have any solution to this? Or is the only solution going to be purchasing an ANSYS license.
      Below I'm going to add the error that pops out as well as the mesh properties I have changed.

    • Ivonne Marti
      Ansys Employee

      Hello Angel,

      In the Ansys Electronics Desktop Student Version | Free Software Download you can find the Mesh element count limit under Product restrictions (see image below).

       If you want to reduce the number of mesh elements in your models I would suggest:

      1.      1. Model only the minimum periodic symmetry (for example 1/8 of the machine)

      2.     2. Specify the surface approximation in the Maxwell 2D/ Mesh/ Initial mesh settings.

      I hope this helps you. Ivonne

      • Angel Tovar Martinez
        Subscriber

        Hi Ivonne! 

        Thanks a lot for you answer! The problem now as follows
        I tried doing 1/4 of the machine and it pops this error now. What could this mean? 

         

    • Yao Liu
      Subscriber

      Hi, Angel!

      I also encountered the same grid size issue when simulating leaky cables, specifically as follows. However, when I modified the length of the leaky cable, the grid size still displayed the same size and reported the same error. What is the reason?

       

Viewing 2 reply threads
  • The topic ‘Mesh Size Limit’ is closed to new replies.