Ansys Products

Ansys Products

Discuss installation & licensing of our Ansys Teaching and Research products

Ansys Mechanical unable to solve

    • Teja Dolzycki
      Subscriber

      Hi I always get the error that AnsysWBU.exe encountered a problem when I try to solve a static-mechanical model.

      I am using the 2023 R2 student version.

      I have reinstaled Ansys several times using admin rights.

      I start workbench as admin.

      I've tried creating several simple models using tutorials, but allways get the same error as above when trying to solve.

      Also I've tried Opening CMD as admin and typing:

      regsvr32.exe ole32.dll
      regsvr32.exe atl.dll
      regsvr32.exe oleaut32.dll
      regsvr32.exe scrrun.dll
      regsvr32.exe jscript.dll
      regsvr32.exe vbscript.dll

      as well as renaming the Ansys folder in %temp% and %appdata%.

      I am using Windows 10 Pro with:

      AMD Ryzen 5 3600X 6-Core Processor, 3800 MHz, 6 Kern(e), 12 logische(r) Prozessor(en),

      NVIDIA GeForce RTX 2080 SUPER, (newest drivers installed)

       

      That's one model:

       

      When analysing the diagnostic file I get:

      *******************************************************************************
      *                                                                             *
      *                        Exception Analysis                                   *
      *                                                                             *
      *******************************************************************************
       
      Failed to request MethodData, not in JIT code range
       
      KEY_VALUES_STRING: 1
       
          Key  : AV.Dereference
          Value: NullPtr
       
          Key  : AV.Fault
          Value: Read
       
          Key  : Analysis.CPU.mSec
          Value: 8749
       
          Key  : Analysis.Elapsed.mSec
          Value: 10372
       
          Key  : Analysis.IO.Other.Mb
          Value: 1
       
          Key  : Analysis.IO.Read.Mb
          Value: 1
       
          Key  : Analysis.IO.Write.Mb
          Value: 3
       
          Key  : Analysis.Init.CPU.mSec
          Value: 906
       
          Key  : Analysis.Init.Elapsed.mSec
          Value: 172459
       
          Key  : Analysis.Memory.CommitPeak.Mb
          Value: 1009
       
          Key  : CLR.BuiltBy
          Value: NET48REL1LAST_B
       
          Key  : CLR.Engine
          Value: CLR
       
          Key  : CLR.Version
          Value: 4.8.4644.0
       
          Key  : Failure.Bucket
          Value: NULL_POINTER_READ_c0000005_Ans.Addins.AnsysSolverCOM.dll!Unknown
       
          Key  : Failure.Hash
          Value: {e42eed70-1967-a50c-8de2-2340605ed18c}
       
          Key  : Timeline.Process.Start.DeltaSec
          Value: 267
       
          Key  : WER.OS.Branch
          Value: vb_release
       
          Key  : WER.OS.Version
          Value: 10.0.19041.1
       
          Key  : WER.Process.Version
          Value: 23.2023.149.1
       
       
      FILE_IN_CAB:  AnsysWBDumpFile.dmp
       
      CONTEXT:  (.ecxr)
      rax=0000000080004005 rbx=000000003538ded8 rcx=0000000000000000
      rdx=000000003538dd30 rsi=000000003538ddc8 rdi=0000000000000000
      rip=0000000023d1d727 rsp=000000003538dd00 rbp=000000003538dd70
       r8=000000003538ded8  r9=0000000000000000 r10=0000000000000180
      r11=000000003538de70 r12=0000000000000000 r13=000000003538df48
      r14=000000003538df38 r15=0000000000000000
      iopl=0         nv up ei pl nz na pe nc
      cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010202
      Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x3fc657:
      00000000`23d1d727 488b01          mov     rax,qword ptr [rcx] ds:00000000`00000000=????????????????
      Resetting default scope
       
      EXCEPTION_RECORD:  (.exr -1)
      ExceptionAddress: 0000000023d1d727 (Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x00000000003fc657)
         ExceptionCode: c0000005 (Access violation)
        ExceptionFlags: 00000000
      NumberParameters: 2
         Parameter[0]: 0000000000000000
         Parameter[1]: 0000000000000000
      Attempt to read from address 0000000000000000
       
      PROCESS_NAME:  AnsysWBU.exe
       
      READ_ADDRESS:  0000000000000000 
       
      ERROR_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%p verwies auf Arbeitsspeicher bei 0x%p. Der Vorgang %s konnte im Arbeitsspeicher nicht durchgef hrt werden.
       
      EXCEPTION_CODE_STR:  c0000005
       
      EXCEPTION_PARAMETER1:  0000000000000000
       
      EXCEPTION_PARAMETER2:  0000000000000000
       
      STACK_TEXT:  
      00000000`3538dd00 00000000`23d57489     : 00000000`8223da00 00007ffc`3430f05b 00000000`3538ded8 00000000`3cf97920 : Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x3fc657
      00000000`3538dda0 00000000`23d69d4f     : 00000000`3538ded8 00000000`00000000 00000000`5f592c40 00000000`5f592c40 : Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x4363b9
      00000000`3538dea0 00000000`23d6ae9c     : 00000000`3538dff8 00000000`00000000 00000000`00000000 00000000`3538e0a9 : Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x448c7f
      00000000`3538e050 00000000`23c07111     : 00000000`00000000 00000000`820c8d30 00000000`820c8d30 00000000`00000001 : Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x449dcc
      00000000`3538e110 00000000`23e4f9c0     : ffffffff`ffffffff ffffffff`ffffffff 00000000`820c8d30 00000000`24039004 : Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x2e6041
      00000000`3538e830 00000000`23d79d1b     : 00000000`656f9c50 00000000`656f9c50 00000000`00000000 00000000`820c8d30 : Ans_Addins_AnsysSolverCOM!DllRuntimeRegisteredCoClasses+0xbd590
      00000000`3538eba0 00000000`353a6780     : 00000000`3538eda0 00000000`65140e68 00000000`65140e68 00000000`3ff7c060 : Ans_Addins_AnsysSolverCOM!DllCanUnloadNow+0x458c4b
      00000000`3538eef0 00000000`353a89a1     : 00000000`3cf97b80 00000000`3063d748 00000000`650ec830 00007ffc`369f5ba1 : Ans_Simulation_VControllerCOM!DllRuntimeRegisteredCoClasses+0x57c0
      00000000`3538f850 00000000`3539f35f     : 00000000`65e2f2f0 00000000`00000000 00000000`30c33a38 00000000`3ff7c378 : Ans_Simulation_VControllerCOM!DllRuntimeRegisteredCoClasses+0x79e1
      00000000`3538fb00 00000000`3539f022     : 00000000`00000001 00000000`3538fbe0 00000000`00000001 00000000`313e0000 : Ans_Simulation_VControllerCOM+0xf35f
      00000000`3538fb60 00000000`3539d4ce     : 00000000`3ff7c060 00000000`00000000 00000000`65e2f2f0 00000000`082c8270 : Ans_Simulation_VControllerCOM+0xf022
      00000000`3538fc10 00000000`322aa681     : 00000000`31077020 00000000`00000000 00000000`005f5ac8 00000000`005f5ac8 : Ans_Simulation_VControllerCOM+0xd4ce
      00000000`3538fec0 00007ffc`351f7614     : 00000000`00000000 00000000`3f6b1fe0 00000000`00152f50 00000000`3fdb8438 : Ans_Simulation_FAManagerCOM!DllRuntimeRegisteredCoClasses+0x7fc1
      00000000`3538ff30 00007ffc`36a226b1     : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x14
      00000000`3538ff60 00000000`00000000     : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x21
       
       
      SYMBOL_NAME:  Ans_Addins_AnsysSolverCOM+3fc657
       
      MODULE_NAME: Ans_Addins_AnsysSolverCOM
       
      IMAGE_NAME:  Ans.Addins.AnsysSolverCOM.dll
       
      STACK_COMMAND:  ~63s; .ecxr ; kb
       
      FAILURE_BUCKET_ID:  NULL_POINTER_READ_c0000005_Ans.Addins.AnsysSolverCOM.dll!Unknown
       
      OS_VERSION:  10.0.19041.1
       
      BUILDLAB_STR:  vb_release
       
      OSPLATFORM_TYPE:  x64
       
      OSNAME:  Windows 10
       
      IMAGE_VERSION:  23.2023.149.1
       
      FAILURE_ID_HASH:  {e42eed70-1967-a50c-8de2-2340605ed18c}
       
      Followup:     MachineOwner
       
       
      I'd really appriciate some help. I've been trying all day to get Ansys to run and solve tht error but no solution I've tried worked.
      Thanks 
      Teja
    • mrife
      Ansys Employee

       

      Hi Teja

      Try turning of Hyperthreading, AMD may use a different term, in the BIOS the try again.  While there make sure nothing is over/under clocked.  Once done you may want to stress test the system with something outside of Ansys like the Prime95 stress test:  https://www.mersenne.org/download/#stresstest

      Mike

       

    • Gary_S
      Ansys Employee

      0xc0000005 is related to permissions or some type of restriction.

      Exception code c0000005 is the code for an access violation. That means that your program is accessing (either reading or writing) a memory address to which it does not have rights.

      Are there any sort of virus scan or endpoint protections programs active?

       

    • Teja Dolzycki
      Subscriber

      Hi

      thanks for the answers! 

      Sadly turning of multithreading didnt help. I let the stresstest run for 30 min and had zero issues or errors.

      I only have microsoft defender running, turning that off didnt help either.

    • Gary_S
      Ansys Employee

       

      You may have run across a bug 882389 when Mechanical queries Engineering Data Material names. 
      Can you try to install 2023R1 to see if issue is same?

       

Viewing 4 reply threads
  • The topic ‘Ansys Mechanical unable to solve’ is closed to new replies.