Another possibility is that the Ansys 2D system was broken at the beginning and is not working properly.

This can happen if you create 2D geometry and open that in Mechanical, but forget to set the Property of the Geometry cell in Workbench to 2D.  The geometry is imported into Mechanical as 3D. You build up the model, then realize it is not in the 2D mode so you can't set it to be Axisymmetric.  You might expect that you can simply go back to the Property setting of the Geometry cell in Workbench and flip it from 3D to 2D.

While this is possible to do, the outcome is not the same as setting the 2D propertry of the Geometry cell BEFORE ever opening the geometry in Mechanical. The only way to fix the problem is to start a new Static Structural and set the Geometry cell to 2D before you open the Model cell.  Then you can build the model and see if that improves the outcome.