I let the first second ramp acceleration up from 0 to 1g with time integration turned off and that had no problem converging.
Then I added 10 seconds of transient with time integration on, and that had no problems. You don't need 10 seconds, maybe 1 extra second. I also added Damping to the Analysis Settings. You must include Damping.
All that was with the Force suppressed.
Add 2 seconds to the time column and let the first 2 seconds have zero force, then start the force after 2 seconds for the length of the transient.