Hey I don't know what you are doing in Step 2, I thought you would only need Step 1 to set the body temperatures and leave Time Integration Off in Step 1.
Then in Step 2, turn on Time Integration.
As you have already done, you Deactivate the two Temperature Loads (one shown below) in Step 2.
I created a simple two block model to test out these settings.
The 30 degree body got a small overshoot at the beginning of Step 2, 30.278 degrees, but less than 1% Green line is the maximum temperature in the body, red line is the minimum temperature in the body.
The 20 degree body also had a small undershoot at the beginning of the simulation as it dipped to 19.722 degrees.