{"id":166285,"date":"2023-03-17T13:11:30","date_gmt":"2023-03-17T13:11:30","guid":{"rendered":"\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/"},"modified":"2023-07-31T12:34:53","modified_gmt":"2023-07-31T12:34:53","slug":"license-log-shows-error-regarding-out-of-file-descriptors","status":"publish","type":"topic","link":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/","title":{"rendered":"License log shows error regarding &#8220;out of file descriptors&#8221;"},"content":{"rendered":"<p>\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn&#8217;t run out of them.      \u2022 On Linux this issue happens when the            \u2022 Username in checkout request is > 20 characters            \u2022 hostname or display name (of client sending the checkout request) is greater than 32 characters      \u2022 On Windows it will only be seen when the number of active connections reach somewhere around 50-60k (without any restart of server)  \u2022Release 21.2 is using FNP version 11.17.2.0 where the above issue is fixed \u2022The changes are only in ansyslmd, lmgrd  To solve this issue, please download the attachments and extract. They include the ansyslmd and lmgrd files. Please backup the current copies in your existing license manager installation and then replace with the new version. The files are located in these directories.  ..Shared FilesLicensingwinx64 &#8211; for Windows ..\/shared_files\/licensing\/linx64 &#8211; for Linux <\/p>\n<p>Attachments:<br \/>\n1. <a href=https:\/\/ansys13.ansys.com\/KnowledgeArticles\/Phase-1\/2063907\/2063907.zip>2063907.zip<\/a><\/p>\n","protected":false},"template":"","class_list":["post-166285","topic","type-topic","status-publish","hentry","topic-tag-2020-r2","topic-tag-installation-licensing-systems","topic-tag-license-server-performance","topic-tag-licensing","topic-tag-workbench-platform-sys"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 4.9.10 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn&#039;t run out of them. \u2022 On Linux this issue happens when the \u2022 Username in checkout request is &gt; 20 characters \u2022 hostname or display name (of\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<link rel=\"canonical\" href=\"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 4.9.10\" \/>\n\t\t<meta property=\"og:locale\" content=\"en_US\" \/>\n\t\t<meta property=\"og:site_name\" content=\"Ansys Knowledge | Ansys Innovation Space\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"License log shows error regarding \u201cout of file descriptors\u201d | Ansys Knowledge\" \/>\n\t\t<meta property=\"og:description\" content=\"\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn&#039;t run out of them. \u2022 On Linux this issue happens when the \u2022 Username in checkout request is &gt; 20 characters \u2022 hostname or display name (of\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-03-17T13:11:30+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-07-31T12:34:53+00:00\" \/>\n\t\t<meta name=\"twitter:card\" content=\"summary_large_image\" \/>\n\t\t<meta name=\"twitter:title\" content=\"License log shows error regarding \u201cout of file descriptors\u201d | Ansys Knowledge\" \/>\n\t\t<meta name=\"twitter:description\" content=\"\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn&#039;t run out of them. \u2022 On Linux this issue happens when the \u2022 Username in checkout request is &gt; 20 characters \u2022 hostname or display name (of\" \/>\n\t\t<script type=\"application\/ld+json\" class=\"aioseo-schema\">\n\t\t\t{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic\\\/license-log-shows-error-regarding-out-of-file-descriptors\\\/#breadcrumblist\",\"itemListElement\":[{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge#listItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/topics\\\/#listItem\",\"name\":\"Topics\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/topics\\\/#listItem\",\"position\":2,\"name\":\"Topics\",\"item\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/topics\\\/\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic-tag\\\/licensing\\\/#listItem\",\"name\":\"licensing\"},\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge#listItem\",\"name\":\"Home\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic-tag\\\/licensing\\\/#listItem\",\"position\":3,\"name\":\"licensing\",\"item\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic-tag\\\/licensing\\\/\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic\\\/license-log-shows-error-regarding-out-of-file-descriptors\\\/#listItem\",\"name\":\"License log shows error regarding &#8220;out of file descriptors&#8221;\"},\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/topics\\\/#listItem\",\"name\":\"Topics\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic\\\/license-log-shows-error-regarding-out-of-file-descriptors\\\/#listItem\",\"position\":4,\"name\":\"License log shows error regarding &#8220;out of file descriptors&#8221;\",\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic-tag\\\/licensing\\\/#listItem\",\"name\":\"licensing\"}}]},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/#organization\",\"name\":\"Ansys Knowledge\",\"description\":\"Ansys Innovation Space\",\"url\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/\"},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic\\\/license-log-shows-error-regarding-out-of-file-descriptors\\\/#webpage\",\"url\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic\\\/license-log-shows-error-regarding-out-of-file-descriptors\\\/\",\"name\":\"License log shows error regarding \\u201cout of file descriptors\\u201d | Ansys Knowledge\",\"description\":\"\\u2022Release 21.1 is using FNP version 11.16.5.1 \\u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn't run out of them. \\u2022 On Linux this issue happens when the \\u2022 Username in checkout request is > 20 characters \\u2022 hostname or display name (of\",\"inLanguage\":\"en-US\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/#website\"},\"breadcrumb\":{\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/forums\\\/topic\\\/license-log-shows-error-regarding-out-of-file-descriptors\\\/#breadcrumblist\"},\"datePublished\":\"2023-03-17T13:11:30+00:00\",\"dateModified\":\"2023-07-31T12:34:53+00:00\"},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/#website\",\"url\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/\",\"name\":\"Ansys Knowledge\",\"description\":\"Ansys Innovation Space\",\"inLanguage\":\"en-US\",\"publisher\":{\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/knowledge\\\/#organization\"}}]}\n\t\t<\/script>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"License log shows error regarding \u201cout of file descriptors\u201d | Ansys Knowledge","description":"\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn't run out of them. \u2022 On Linux this issue happens when the \u2022 Username in checkout request is > 20 characters \u2022 hostname or display name (of","canonical_url":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"BreadcrumbList","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge#listItem","position":1,"name":"Home","item":"https:\/\/innovationspace.ansys.com\/knowledge","nextItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/topics\/#listItem","name":"Topics"}},{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/topics\/#listItem","position":2,"name":"Topics","item":"https:\/\/innovationspace.ansys.com\/knowledge\/topics\/","nextItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic-tag\/licensing\/#listItem","name":"licensing"},"previousItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge#listItem","name":"Home"}},{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic-tag\/licensing\/#listItem","position":3,"name":"licensing","item":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic-tag\/licensing\/","nextItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/#listItem","name":"License log shows error regarding &#8220;out of file descriptors&#8221;"},"previousItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/topics\/#listItem","name":"Topics"}},{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/#listItem","position":4,"name":"License log shows error regarding &#8220;out of file descriptors&#8221;","previousItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic-tag\/licensing\/#listItem","name":"licensing"}}]},{"@type":"Organization","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/#organization","name":"Ansys Knowledge","description":"Ansys Innovation Space","url":"https:\/\/innovationspace.ansys.com\/knowledge\/"},{"@type":"WebPage","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/#webpage","url":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/","name":"License log shows error regarding \u201cout of file descriptors\u201d | Ansys Knowledge","description":"\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn't run out of them. \u2022 On Linux this issue happens when the \u2022 Username in checkout request is > 20 characters \u2022 hostname or display name (of","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/innovationspace.ansys.com\/knowledge\/#website"},"breadcrumb":{"@id":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/#breadcrumblist"},"datePublished":"2023-03-17T13:11:30+00:00","dateModified":"2023-07-31T12:34:53+00:00"},{"@type":"WebSite","@id":"https:\/\/innovationspace.ansys.com\/knowledge\/#website","url":"https:\/\/innovationspace.ansys.com\/knowledge\/","name":"Ansys Knowledge","description":"Ansys Innovation Space","inLanguage":"en-US","publisher":{"@id":"https:\/\/innovationspace.ansys.com\/knowledge\/#organization"}}]},"og:locale":"en_US","og:site_name":"Ansys Knowledge | Ansys Innovation Space","og:type":"article","og:title":"License log shows error regarding \u201cout of file descriptors\u201d | Ansys Knowledge","og:description":"\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn't run out of them. \u2022 On Linux this issue happens when the \u2022 Username in checkout request is &gt; 20 characters \u2022 hostname or display name (of","og:url":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/","article:published_time":"2023-03-17T13:11:30+00:00","article:modified_time":"2023-07-31T12:34:53+00:00","twitter:card":"summary_large_image","twitter:title":"License log shows error regarding \u201cout of file descriptors\u201d | Ansys Knowledge","twitter:description":"\u2022Release 21.1 is using FNP version 11.16.5.1 \u2022The issue is FNP will incorrectly fail with a message that you ran out of file descriptors even though you didn't run out of them. \u2022 On Linux this issue happens when the \u2022 Username in checkout request is &gt; 20 characters \u2022 hostname or display name (of"},"aioseo_meta_data":{"post_id":"166285","title":null,"description":null,"keywords":null,"keyphrases":null,"primary_term":null,"canonical_url":null,"og_title":null,"og_description":null,"og_object_type":"default","og_image_type":"default","og_image_url":null,"og_image_width":null,"og_image_height":null,"og_image_custom_url":null,"og_image_custom_fields":null,"og_video":null,"og_custom_url":null,"og_article_section":null,"og_article_tags":null,"twitter_use_og":false,"twitter_card":"default","twitter_image_type":"default","twitter_image_url":null,"twitter_image_custom_url":null,"twitter_image_custom_fields":null,"twitter_title":null,"twitter_description":null,"schema":{"blockGraphs":[],"customGraphs":[],"default":{"data":{"Article":[],"Course":[],"Dataset":[],"FAQPage":[],"Movie":[],"Person":[],"Product":[],"ProductReview":[],"Car":[],"Recipe":[],"Service":[],"SoftwareApplication":[],"WebPage":[]},"graphName":"","isEnabled":true},"graphs":[]},"schema_type":"default","schema_type_options":null,"pillar_content":false,"robots_default":true,"robots_noindex":false,"robots_noarchive":false,"robots_nosnippet":false,"robots_nofollow":false,"robots_noimageindex":false,"robots_noodp":false,"robots_notranslate":false,"robots_max_snippet":null,"robots_max_videopreview":null,"robots_max_imagepreview":"large","priority":null,"frequency":null,"local_seo":null,"limit_modified_date":false,"created":"2025-10-17 22:55:22","updated":"2026-07-30 13:47:51","ai":null,"breadcrumb_settings":null,"seo_analyzer_scan_date":null},"aioseo_breadcrumb":"<div class=\"aioseo-breadcrumbs\"><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/innovationspace.ansys.com\/knowledge\" title=\"Home\">Home<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/innovationspace.ansys.com\/knowledge\/topics\/\" title=\"Topics\">Topics<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic-tag\/licensing\/\" title=\"licensing\">licensing<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\tLicense log shows error regarding \u201cout of file descriptors\u201d\n\t\t<\/span><\/div>","aioseo_breadcrumb_json":[{"label":"Home","link":"https:\/\/innovationspace.ansys.com\/knowledge"},{"label":"Topics","link":"https:\/\/innovationspace.ansys.com\/knowledge\/topics\/"},{"label":"licensing","link":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic-tag\/licensing\/"},{"label":"License log shows error regarding &#8220;out of file descriptors&#8221;","link":"https:\/\/innovationspace.ansys.com\/knowledge\/forums\/topic\/license-log-shows-error-regarding-out-of-file-descriptors\/"}],"acf":[],"custom_fields":[{"0":{"_wp_page_template":["default"],"_bbp_last_active_time":["3\/15\/2023 20:20"],"_bbp_forum_id":["153867"],"_bbp_author_ip":["23.56.168.180"],"_btv_view_count":["398"],"siebel_km_number":["2063907"],"product_version":["2020 R2"],"km_published_date":["2021-01-08T21:30:12.000Z"],"family":["Installation\/Licensing\/Systems"],"application_name":["Workbench Platform - SYS"]},"test":"solution"}],"_links":{"self":[{"href":"https:\/\/innovationspace.ansys.com\/knowledge\/wp-json\/wp\/v2\/topics\/166285","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/innovationspace.ansys.com\/knowledge\/wp-json\/wp\/v2\/topics"}],"about":[{"href":"https:\/\/innovationspace.ansys.com\/knowledge\/wp-json\/wp\/v2\/types\/topic"}],"version-history":[{"count":0,"href":"https:\/\/innovationspace.ansys.com\/knowledge\/wp-json\/wp\/v2\/topics\/166285\/revisions"}],"wp:attachment":[{"href":"https:\/\/innovationspace.ansys.com\/knowledge\/wp-json\/wp\/v2\/media?parent=166285"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}