


{"id":159924,"date":"2021-06-28T15:23:48","date_gmt":"2021-06-28T15:23:48","guid":{"rendered":"\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/"},"modified":"2021-07-29T15:41:51","modified_gmt":"2021-07-29T15:41:51","slug":"fmu-fail-to-load-on-linux-cluster","status":"closed","type":"topic","link":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/","title":{"rendered":"FMU fail to load on Linux cluster"},"content":{"rendered":"<div class=\"Item-Body\">\n<div class=\"Message userContent\">\n<p>Hello,<\/p>\n<p>I&#039;m looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :<\/p>\n<p>&quot;0 is an invalid FMU instance ID&quot;, &quot;FMU Library TEST-xxxxx\/binaries\/linux64\/TEST.so failed to load&quot;<\/p>\n<p>I&#039;m using an FMU that has been generated in Dymola using the WSL Linux cross-compiler, and I&#039;ve tested the FMU file using FMPy on an Ubuntu installation and everything works fine. The case was setup through the fluent GUI on the Linux machine using the Linux compiled FMU and the exact same steps as the Windows version that runs without errors, and the FMU generates input parameters that can be used as boundary conditions and accepts output parameters from the solution.<\/p>\n<p>The error then occurs when the simulation is initialized.<\/p>\n<p>I&#039;d be very grateful if anyone has any insight into what this error could be or ways to solve it!<\/p>\n<p>Many thanks, Conor<\/p>\n","protected":false},"template":"","class_list":["post-159924","topic","type-topic","status-closed","hentry","topic-tag-co-simulation","topic-tag-linux"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 4.9.10 - aioseo.com -->\n\t<meta name=\"description\" content=\"Hello,I&#039;m looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :&quot;0 is an invalid FMU instance ID&quot;, &quot;FMU\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<link rel=\"canonical\" href=\"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 4.9.10\" \/>\n\t\t<meta property=\"og:locale\" content=\"en_US\" \/>\n\t\t<meta property=\"og:site_name\" content=\"Ansys Learning Forum | Ansys Innovation Space\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"FMU fail to load on Linux cluster | Ansys Learning Forum\" \/>\n\t\t<meta property=\"og:description\" content=\"Hello,I&#039;m looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :&quot;0 is an invalid FMU instance ID&quot;, &quot;FMU\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2021-06-28T15:23:48+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2021-07-29T15:41:51+00:00\" \/>\n\t\t<meta name=\"twitter:card\" content=\"summary_large_image\" \/>\n\t\t<meta name=\"twitter:title\" content=\"FMU fail to load on Linux cluster | Ansys Learning Forum\" \/>\n\t\t<meta name=\"twitter:description\" content=\"Hello,I&#039;m looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :&quot;0 is an invalid FMU instance ID&quot;, &quot;FMU\" \/>\n\t\t<script type=\"application\/ld+json\" class=\"aioseo-schema\">\n\t\t\t{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic\\\/fmu-fail-to-load-on-linux-cluster\\\/#breadcrumblist\",\"itemListElement\":[{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum#listItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/topics\\\/#listItem\",\"name\":\"Topics\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/topics\\\/#listItem\",\"position\":2,\"name\":\"Topics\",\"item\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/topics\\\/\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic-tag\\\/linux\\\/#listItem\",\"name\":\"linux\"},\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum#listItem\",\"name\":\"Home\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic-tag\\\/linux\\\/#listItem\",\"position\":3,\"name\":\"linux\",\"item\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic-tag\\\/linux\\\/\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic\\\/fmu-fail-to-load-on-linux-cluster\\\/#listItem\",\"name\":\"FMU fail to load on Linux cluster\"},\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/topics\\\/#listItem\",\"name\":\"Topics\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic\\\/fmu-fail-to-load-on-linux-cluster\\\/#listItem\",\"position\":4,\"name\":\"FMU fail to load on Linux cluster\",\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic-tag\\\/linux\\\/#listItem\",\"name\":\"linux\"}}]},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/#organization\",\"name\":\"Ansys Learning Forum\",\"description\":\"Ansys Innovation Space\",\"url\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/\"},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic\\\/fmu-fail-to-load-on-linux-cluster\\\/#webpage\",\"url\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic\\\/fmu-fail-to-load-on-linux-cluster\\\/\",\"name\":\"FMU fail to load on Linux cluster | Ansys Learning Forum\",\"description\":\"Hello,I'm looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :\\\"0 is an invalid FMU instance ID\\\", \\\"FMU\",\"inLanguage\":\"en-US\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/#website\"},\"breadcrumb\":{\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/forums\\\/topic\\\/fmu-fail-to-load-on-linux-cluster\\\/#breadcrumblist\"},\"datePublished\":\"2021-06-28T15:23:48+00:00\",\"dateModified\":\"2021-07-29T15:41:51+00:00\"},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/#website\",\"url\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/\",\"name\":\"Ansys Learning Forum\",\"description\":\"Ansys Innovation Space\",\"inLanguage\":\"en-US\",\"publisher\":{\"@id\":\"https:\\\/\\\/innovationspace.ansys.com\\\/forum\\\/#organization\"}}]}\n\t\t<\/script>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"FMU fail to load on Linux cluster | Ansys Learning Forum","description":"Hello,I'm looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :\"0 is an invalid FMU instance ID\", \"FMU","canonical_url":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"BreadcrumbList","@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum#listItem","position":1,"name":"Home","item":"https:\/\/innovationspace.ansys.com\/forum","nextItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/topics\/#listItem","name":"Topics"}},{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/topics\/#listItem","position":2,"name":"Topics","item":"https:\/\/innovationspace.ansys.com\/forum\/topics\/","nextItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic-tag\/linux\/#listItem","name":"linux"},"previousItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum#listItem","name":"Home"}},{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic-tag\/linux\/#listItem","position":3,"name":"linux","item":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic-tag\/linux\/","nextItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/#listItem","name":"FMU fail to load on Linux cluster"},"previousItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/topics\/#listItem","name":"Topics"}},{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/#listItem","position":4,"name":"FMU fail to load on Linux cluster","previousItem":{"@type":"ListItem","@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic-tag\/linux\/#listItem","name":"linux"}}]},{"@type":"Organization","@id":"https:\/\/innovationspace.ansys.com\/forum\/#organization","name":"Ansys Learning Forum","description":"Ansys Innovation Space","url":"https:\/\/innovationspace.ansys.com\/forum\/"},{"@type":"WebPage","@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/#webpage","url":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/","name":"FMU fail to load on Linux cluster | Ansys Learning Forum","description":"Hello,I'm looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :\"0 is an invalid FMU instance ID\", \"FMU","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/innovationspace.ansys.com\/forum\/#website"},"breadcrumb":{"@id":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/#breadcrumblist"},"datePublished":"2021-06-28T15:23:48+00:00","dateModified":"2021-07-29T15:41:51+00:00"},{"@type":"WebSite","@id":"https:\/\/innovationspace.ansys.com\/forum\/#website","url":"https:\/\/innovationspace.ansys.com\/forum\/","name":"Ansys Learning Forum","description":"Ansys Innovation Space","inLanguage":"en-US","publisher":{"@id":"https:\/\/innovationspace.ansys.com\/forum\/#organization"}}]},"og:locale":"en_US","og:site_name":"Ansys Learning Forum | Ansys Innovation Space","og:type":"article","og:title":"FMU fail to load on Linux cluster | Ansys Learning Forum","og:description":"Hello,I'm looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :&quot;0 is an invalid FMU instance ID&quot;, &quot;FMU","og:url":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/","article:published_time":"2021-06-28T15:23:48+00:00","article:modified_time":"2021-07-29T15:41:51+00:00","twitter:card":"summary_large_image","twitter:title":"FMU fail to load on Linux cluster | Ansys Learning Forum","twitter:description":"Hello,I'm looking to use the FMU import function to run analysis with changing boundary conditions determined by an FMU. The setup works perfectly on my Windows system but when the case is sent to a Linux cluster it returns an error when the FMU is initialized saying :&quot;0 is an invalid FMU instance ID&quot;, &quot;FMU"},"aioseo_meta_data":{"post_id":"159924","title":null,"description":null,"keywords":null,"keyphrases":null,"primary_term":null,"canonical_url":null,"og_title":null,"og_description":null,"og_object_type":"default","og_image_type":"content","og_image_url":null,"og_image_width":null,"og_image_height":null,"og_image_custom_url":null,"og_image_custom_fields":null,"og_video":null,"og_custom_url":null,"og_article_section":null,"og_article_tags":null,"twitter_use_og":true,"twitter_card":"default","twitter_image_type":"default","twitter_image_url":null,"twitter_image_custom_url":null,"twitter_image_custom_fields":null,"twitter_title":null,"twitter_description":null,"schema":{"blockGraphs":[],"customGraphs":[],"default":{"data":{"Article":[],"Course":[],"Dataset":[],"FAQPage":[],"Movie":[],"Person":[],"Product":[],"ProductReview":[],"Car":[],"Recipe":[],"Service":[],"SoftwareApplication":[],"WebPage":[]},"graphName":"","isEnabled":true},"graphs":[]},"schema_type":"default","schema_type_options":null,"pillar_content":false,"robots_default":true,"robots_noindex":false,"robots_noarchive":false,"robots_nosnippet":false,"robots_nofollow":false,"robots_noimageindex":false,"robots_noodp":false,"robots_notranslate":false,"robots_max_snippet":null,"robots_max_videopreview":null,"robots_max_imagepreview":"large","priority":null,"frequency":null,"local_seo":null,"limit_modified_date":false,"created":"2024-10-28 20:29:50","updated":"2024-10-28 20:29:50","ai":null,"breadcrumb_settings":null,"seo_analyzer_scan_date":null},"aioseo_breadcrumb":"<div class=\"aioseo-breadcrumbs\"><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/innovationspace.ansys.com\/forum\" title=\"Home\">Home<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/innovationspace.ansys.com\/forum\/topics\/\" title=\"Topics\">Topics<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic-tag\/linux\/\" title=\"linux\">linux<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\tFMU fail to load on Linux cluster\n\t\t<\/span><\/div>","aioseo_breadcrumb_json":[{"label":"Home","link":"https:\/\/innovationspace.ansys.com\/forum"},{"label":"Topics","link":"https:\/\/innovationspace.ansys.com\/forum\/topics\/"},{"label":"linux","link":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic-tag\/linux\/"},{"label":"FMU fail to load on Linux cluster","link":"https:\/\/innovationspace.ansys.com\/forum\/forums\/topic\/fmu-fail-to-load-on-linux-cluster\/"}],"acf":[],"custom_fields":[{"0":{"_bbp_author_ip":[""],"_bbp_old_reply_author_name_id":["Anonymous"],"_bbp_old_is_reply_anonymous_id":["false"],"_btv_view_count":["952"],"_bbp_likes_count":["0"],"_bbp_subscription":["250496"],"_bbp_topic_status":["unanswered"],"_bbp_status":["publish"],"_bbp_topic_id":["159924"],"_bbp_forum_id":["27792"],"_bbp_engagement":["118","207796"],"_bbp_voice_count":["2"],"_bbp_reply_count":["4"],"_bbp_last_reply_id":["183778"],"_bbp_last_active_id":["183778"],"_bbp_last_active_time":["2021-07-29 15:41:51"]},"test":"coboyle15qub-ac-uk"}],"_links":{"self":[{"href":"https:\/\/innovationspace.ansys.com\/forum\/wp-json\/wp\/v2\/topics\/159924","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/innovationspace.ansys.com\/forum\/wp-json\/wp\/v2\/topics"}],"about":[{"href":"https:\/\/innovationspace.ansys.com\/forum\/wp-json\/wp\/v2\/types\/topic"}],"version-history":[{"count":0,"href":"https:\/\/innovationspace.ansys.com\/forum\/wp-json\/wp\/v2\/topics\/159924\/revisions"}],"wp:attachment":[{"href":"https:\/\/innovationspace.ansys.com\/forum\/wp-json\/wp\/v2\/media?parent=159924"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}