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Overview

• Introduction to Ansys Maxwell

• Modeling

‐ Geometry and Import

‐ Materials, boundaries and sources

• Parameterization

• Adaptive meshing

• Inductance calculation

• Postprocessing 1

• Workshop 1: Magnetostatic Analysis
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Basics

Module 1

Post-processing
and parametric

Quasi Static
(QS) Solvers

Module 2

Module 3

Module 4

Overall Process
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*BusinessWeek, FORTUNE 

Ansys is the Simulation Leader 

FOCUSED
This is all we do.
Leading product technologies in all physics areas
Largest development team focused on simulation

CAPABLE
2,700+ 

75 

40 

employees

locations

countries

FORTUNE 500 Industrials 

TRUSTED

96 of the top 100 

ISO 9001 and NQA-1 certified

PROVEN
Recognized as one of the world’s MOST INNOVATIVE 
AND FASTEST-GROWING COMPANIES*

INDEPENDENT
Long-term financial stability

CAD agnostic

LARGEST

3x The size of our 
nearest competitor
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Structural Mechanics:
From Linear Statics  

Fluid Mechanics: 
From Single-Phase Flows  

Electromagnetics: From 
Low-Frequency Windings

Systems:
From Data Sharing

To High-Speed Impact

To Multiphase 
Combustion

To High-Frequency 
Field Analysis

To Multi-Domain 
System Analysis

Breadth of Technologies
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Ansys Learning Hub Functions

Learn whenever you like

Mix and match – pick modules 
that you need

Self-paced videos - Go back and 
review with searchable captions

Search global course schedule 
and access materials

Register for live and virtual 
classrooms

Ask questions in the 
interactive Learning Room
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Introduction to Ansys Maxwell 

• Maxwell is an electro-magnetic tool suitable to analyse low-frequency phenomena and devices 

• Maxwell is integrated into the Electronics Desktop, together with all the other Ansys Electromagnetic tools

• Maxwell can be integrated in the Workbench Platform for Multiphysics analysis 

• Geometries can be created either directly inside Maxwell or imported from external CAD tools

• Quasi-static Solvers offer an automatic meshing refinement algorithm

• Transient solver allows the analysis of large movements and mechanical transients
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Introduction to Ansys Maxwell

• Ansys Maxwell is a high-performance interactive software package that uses finite element analysis (FEA) to solve 
electric or magnetic problems.

• Maxwell solves the electromagnetic field problems by solving Maxwell's equations in a finite region of space with 
appropriate boundary conditions and user-specified initial conditions in order to obtain a solution with 
guaranteed uniqueness.

• Appropriate set of equations and its terms are used based on the solver selected such as Electrostatic, 
Magnetostatic, Eddy Current and Magnetic Transient.

𝛻 × 𝑯 = 𝑱 +
𝜕𝑫

𝜕𝑡

𝛻 ∙ 𝑩 = 0

𝛻 × 𝑬 = −
𝜕𝑩

𝜕𝑡

𝛻 ∙ 𝑫 = 𝜌
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Finite    ElementsFinite        
Difference

Differential 
Equations

Integral Equations

Numerical 
Techniques

Electromagnetic 
Analysis

Analytical 
Techniques

Introduction to Ansys Maxwell 

Flowchart of General Finite Element Analysis Method

▪ Finite elements have proven to be very robust 
for general electromagnetic analysis

Scalar  
Potentials

Vector  
Potentials

Components of H-
Field

Closed Form

BEM

FDM FEM

Iterative

3D Magnetostatic

3D Eddy

3D Transient

2D Magnetostatic

2D Eddy

2D Transient

2D Electrostatic

2D/3D Thermal

3D Electrostatic

Boundary Elements
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Menu bar Toolbars

Project Manager 
Window

Properties Window

Message  Window

Progress  Window

Modeler  Window

History  
tree

Status Bar Coordinate Entry Field

Graphical User Interface (GUI)

Project Manager 
Window

Properties Window

Message  Window

Progress  Window

Status Bar Coordinate Entry Field
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Graphical User Interface (GUI)

• Project Manager window

‐ Project Manager window contains all the details of Problem Setup done for any project

Project Name (multiple projects per Desktop)

Design Name (multiple Designs per Project, Can be a 
combination of Maxwell 3D, 2D,  RMXprt and External 
Circuit)

Design Setup

Analysis Setup (Can contain multiple setups )

Optimetrics Analysis Setups

Postprocessed Results
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Adding a Maxwell design

• Adding a Design to Maxwell

‐ A design can be added to a Maxwell project from the Project menu bar or selecting icon from 

• Maxwell Design Types

‐ RMxprt:

• Rotating Machinery Expert is an interactive analytical tool used for designing and analyzing electrical machines 

‐ Maxwell 2D:

• Maxwell 2D uses Finite Element Analysis to simulate and solve 2D electromagnetic fields in XY or RZ planes

‐ Maxwell 3D:

• Maxwell 3D uses Finite Element Analysis to simulate and solve three dimensional electromagnetic fields.

Note: Most of the lectures in this course are focused on Maxwell 2D and Maxwell 3D and do not cover RMxprt.
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Graphical User Interface (GUI)

• History Tree

‐ History tree contains details of all geometrical operations performed in a Design

‐ Any line, surface or solid objects, coordinate systems or its planes can be accessed from History tree

‐ Solid objects are categorized based on assigned materials in 3D while in 2D sheet objects are categorized

• Toolbars

‐ Most of the menu bar commands can be accessed from Toolbar as an icon

‐ Toolbar can be customized to add or remove any options by right clicking on Toolbar or selecting the menu item 
Tools 
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Graphical User Interface (GUI)

• Properties Window

‐ Shows all the properties of selected entities

‐ Selected entity can be any geometrical object, performed geometrical operations from history tree or any added 
setup entities selected from Project Manager window

‐ Display of Properties window will change based on selected entity

Note: Double clicking on any selected entity will also initiate a dialog box for property display and editing
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Graphical User Interface (GUI)

• Coordinate Entry Field

‐ This window appears whenever an operation requires entry of coordinates

‐ Coordinate values can be entered in Cartesian, Cylindrical or Spherical form

• Message Window

‐ Displays Error, Warning or Information messages resulting from an operation

‐ Messages can be Copy-Pasted to text file if required

• Status Bar

‐ Shows status of Maxwell window, prompts next course of action for any geometrical operation or information 
about any command on which mouse is placed

• Progress Window

‐ Shows progress of Analysis operation being carried out
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Graphical User Interface (GUI)

• Modeler Window

‐ Modeler window enables users to view and interact with geometry dynamically. 

‐ Geometry in Modeler window can be Manipulated either using Toolbar commands or Mouse-keyboard keys

‐ Right Mouse click in Modeler window also gives access to various menu bar commands through context window

• Mouse Commands for Geometry Manipulation

‐ Zoom: Left click and drag the mouse button with SHIFT+ALT pressed

‐ Pan: Left click and drag the mouse button with SHIFT pressed

‐ Rotate: Left click and drag the mouse button with ALT pressed



©2020 ANSYS, Inc. Unauthorized use, distribution, or duplication is prohibited.17

Solvers in Maxwell

• Setting a Solver Type

‐ Appropriate Maxwell solver can be selected based on the application being solved. 

‐ Solver type can be set by selecting the menu item Maxwell 3D/2D → Solution Type

‐ For 2D, users can also specify if the problem will be solved in XY or RZ plane

Maxwell 3D Maxwell 2D
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Solvers in Maxwell

• Magnetic Solvers

‐ Magnetostatic Solver

• Solves Static magnetic fields caused by DC currents and permanent magnets. Can solve both Linear and 
nonlinear materials

‐ Eddy Current Solver

• Solves sinusoidally-varying magnetic fields in frequency domain. Solves both Linear and nonlinear materials 
(creating energy-equivalent sinusoidal fields). Considers displacement currents. Induced fields such as skin and 
current proximity effects are also considered

‐ Transient Magnetic 

• Solves Transient magnetic fields caused by time-varying or moving electrical sources and permanent magnets 
in Linear or Non-linear materials. Induced fields such as skin and current proximity effects are considered 

Note: Capacitive effects are not considered by Magnetic Solvers in Maxwell. These effects need to be accounted for 
separately
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Solvers in Maxwell

• Electric Solvers

‐ Electrostatic Solver

• Solves Static Electric Fields in linear materials

• DC Conduction 

‐ Solves for voltage, electric field, and the current density from the potential. Can solve electric fields in insulators 
as well

• AC Conduction (2D only)

‐ Solves sinusoidally-varying electric fields in Frequency domain. Available only with 2D solver

• Transient Electric 

‐ Transient electric fields caused by time-varying voltages, charge distributions, or current excitations in 
inhomogeneous materials. Electric potential is the solution quantity
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Maxwell files structure

• File Structure in Maxwell

‐ FileName.aedt

• This file contains all the information related to Maxwell project apart from results. The file is written in ASCII 
format. 

‐ FileName.aedtresults

• This folder contains the mesh and solution related files. Users need to copy both .aedt file and this folder in 
order to transfer the project with results

‐ FileName.aedt.lock

• This is a lock file created when file is open to avoid overwriting of file from multiple sessions

‐ FileName.aedt.auto

• Autosave file in order to recover lost data in case of unusual file closure. Created only when Autosave is turned 
ON
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Maxwell Folders

• Maxwell Folders

‐ Maxwell Folder locations can be set from the menu item Tools → Options → General → Directories

• Project: The default location  where Maxwell 
project file is saved

• Temp: Location for saving Temporary results 
files. Files will be deleted once project is saved

• SysLib: Global level directory predefined by Ansys 
and ships with new upgrades

• UserLib: Can host user created material 
libraries or script files. Can be shared among 
all users at a company

• PersonalLib: Can host user created material
libraries or script files. Accessible only the 
user who creates it
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Maxwell Material Libraries

• Maxwell Material Libraries

‐ Maxwell default material library is loaded with Maxwell installation and is available under Syslib directory. This 
material database can not be modified by users

‐ Users can add their own material database to Personal or User library directories 

‐ Once the file is added, users can select and assign material from the added library
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Maxwell Help

• Maxwell Help manual can be accessed from following locations:

• From menu item Help → Maxwell Help or using the shortcut F1:

• This will open the following web page
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Maxwell Help

• From menu item Help → Maxwell PDFs → Maxwell Help:

• This will open the following file:



Adaptive Meshing and 
Magnetostatic Solver
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Maxwell Adaptive Meshing

• Adaptive Meshing

‐ For most of the cases, initial mesh is very coarse and more or less uniform in size throughout the region

‐ To achieve required level of accuracy in results, this mesh needs to be refined in areas where fields are of 
interest or the field gradients are high

‐ Adaptive meshing provides automated mesh refinement capability based on reported energy error in simulation

‐ Adaptive meshing is available only with static solvers

Initial Mesh Adaptively Refined 
Mesh
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Maxwell Adaptive Meshing

• Adaptive Meshing Workflow

‐ Adaptive meshing technique starts with initial 
mesh and refines it until required accuracy (Energy 
% error) is met or Maximum number of passes is 
reached

Calculate local
Solution error

Generate Initial
Mesh

Solve fields using the
Finite Element Method

End criteria 
reached ?

Refine Mesh

Calculate Outputs 
(Force, Inductance, etc.)

no

yes

Start
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Maxwell Magnetostatic Solver

• Magnetostatic Solver

‐ In the Magnetostatic Solver, a static magnetic field is solved resulting from a DC current flowing through a coil or 
due to a permanent magnet

‐ The Electric field inside the current carrying coil is completely decoupled from magnetic field

‐ Losses are only due to Ohmic losses in current carrying conductors

‐ The Magnetostatic solver utilizes the automatic adaptive mesh refinement technique

• Magnetostatic Equations

‐ Following Maxwell’s equations are solved with Magnetostatic solver

Maxwell 3D Maxwell 2D

Cartesian XY

Cylindrical 
about Z

𝛻 × 𝑯 = 𝑱

𝛻 ∙ 𝑩 = 0

𝑩 = 𝜇0𝜇𝑟 𝑯 ∙ 𝑯

𝑱𝒛 𝑥, 𝑦 = 𝛻 ×
1

𝜇0𝜇𝑟
∙ 𝛻 × 𝑨𝑧 𝑥, 𝑦

𝑱𝝋 𝑟, 𝑧 = 𝛻 ×
1

𝜇0𝜇𝑟
∙ 𝛻 × 𝑨𝜑 𝑟, 𝑧
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Selecting the Magnetostatic Solver

• Selecting the Magnetostatic Solver

‐ By default, any newly created design will be set as a Magnetostatic problem

‐ Specify the Magnetostatic Solver by selecting the menu item Maxwell 2D/3D → Solution Type

‐ In Solution type window, select Magnetic → Magnetostatic and press OK

‐ In Maxwell 2D it is possible to choose between Cartesian XY and Cylindrical about Z symmetry

Maxwell 3D Maxwell 2D
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Materials Definition

• Magnetostatic Material Properties

‐ In a Magnetostatic simulation, the following parameters may be defined for a material (by clicking on the pull-
down menu under Type and Value)

‐ Relative Permeability 

• Relative permeability can be either Simple (linear µr) or 
Nonlinear (BH Curve) or/and anisotropic

‐ Bulk Conductivity

• Used to determine the current distribution in conductors

• Can be Simple or Anisotropic

‐ Magnetic Coercivity

• Used to define permanent magnets properties.

• Requires magnitude and direction specification. 

• Direction specified is with respect to Orientation CS of 
bodies to which material is assigned

‐ Composition

• Can be Solid or Lamination

• Requires specification of direction normal to laminated 
pack and stacking factor
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Boundary Conditions

• Assigning Boundary Conditions 

‐ Boundary conditions define behavior of the magnetic field at the interfaces or the edges of the problem region

‐ A boundary can be assigned to an edge/face from menu item Maxwell 2D/3D → Boundaries → Assign and 
select the required boundary assignment

• Boundary Types (3D)

‐ Default (No Boundary Assigned)

When no boundary is specified for a surface, following 
two treatments are assigned based on the surface position:

‐ Natural: for the boundaries on the interface between 
objects. It describes the natural variation from one  
material to the next one, as defined by material properties

‐ Neumann: For exterior boundaries of solution domain. 
H Field is tangential to the boundary and flux cannot cross it

Natural

Neumann

H Vectors
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Boundary Conditions

• Boundary Types (3D)

− Tangential H-Field
• Useful to assign external field. 
• Tangential H field applied using U and V vectors
• Applied to external boundaries of the domain

− Insulating
• Same as Neumann, except that current 

cannot cross the boundary. 
• Used to insulate two conductors which 

are in contact with each other

J Vectors without 
insulating boundary

J Vectors with 
insulating boundary

− Zero Tangential H-Field
• Useful to assign external field. 
• H field is normal to assigned surface
• Applied to external boundaries of the domain

H field on Zero 
Tangential H field 
boundary

H field on Tangential 
H field boundary

32
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Boundary Conditions

• Boundary Types (2D)

‐ Vector Potential: 

‐ Sets the specified value of magnetic vector potential 
on the boundary.

‐ Used to model Magnetically isolated structures.

‐ Balloon: 

‐ Models the region outside drawing space as being 
infinitely large.

‐ Magnetic flux lines are neither tangential nor normal 
to the boundary

• Note: In 2D, no default boundary condition is assigned to the simulation region edges. Users have to specify the 
behavior of simulation boundaries by assigning either Balloon or Vector Potential boundary. 

Flux lines with zero 
Vector Potential

Flux lines with 
Balloon
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Boundary Conditions

• Boundary Types (2D & 3D): 

− Independent/Dependent :

− Enables to model only one period of a 
periodic structure, reducing design size

− Magnetic fields at Independent and
Dependent boundaries match each 
other

− Symmetry Boundary:

• Enables to model only part of a 
structure, reducing design size

Symmetry Even: Same as Zero 
Tangential H-Field boundary 
(Flux Normal)

Symmetry Odd: Same as default 
Boundary (Flux Tangential)

1/8th

Model

Dep = Indep

Dep = - Indep

1/4th

Model
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Excitations (energy sources)

• Excitations (2D & 3D)

‐ Excitations can be assigned from the menu item Maxwell 2D/3D → Excitations → Assign

• Current

‐ Used in most magnetostatic analysis cases, 

‐ Assigned to 2D sheets (conductor sections) defining total current in Amp-turns through the conductors

‐ The conducting path can be either a closed loop or start&stop on simulation domain outer boundary

‐ Conductor defined as Solid or Stranded

Start&stop Closed loop
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Excitations (energy sources)

• Excitations (2D and 3D)

‐ Current Density

• In practical applications this kind of source is seldom used 

• In 3D, this definition should be accompanied with Current 
Density Terminal definition

• Defined using X,Y and Z components of selected CS

‐ Current  Density Terminal (3D only)

• Required to be defined if Current Density is set

• Can be assigned for either closed loop or start&stop conducting 
paths
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Excitations (energy sources)

• Excitation (3D)

− Voltage

• Used in conjunction with material conductivity to 
define current through a solid conductor

• Can only be assigned to faces or sheets lying on 
simulation domain boundaries

− Voltage Drop

• Similar to the voltage definition
• Can only be assigned to conductor sections
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Excitations (energy sources)

• Further Energy Sources (2D and/or 3D)

− Permanent Magnets (2D and 3D)

• Defining objects as permanent magnets (through material properties) represents setting an energy source

− Tangential H-Field (3D)

• Defining the boundary Tangential H-Field is often used to create an external H-field surrounding all the 
devices under investigation and it is considered by the solver as an energy source

− Vector Potential Gradients (2D)

• Defining Vector Potential gradients on 2D boundaries is used to create external magnetic field surrounding all 
the devices under investigation and it is considered by the solver as an energy source
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Parameters

• Parameters

• Three parameters can be assigned for magnetostatic solver: Force, Torque, Matrix

• Parameters can be added through menu item Maxwell 3D/2D → Parameters → Assign

− Force:

• Calculates force acting on selected objects
• Can be Virtual or Lorentz
• Lorentz can not be used for magnetic materials

− Torque:

• Calculates torque on selected objects
• Can be Virtual or Lorentz
• The torque acting axis and direction must be set 
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Individual turns 
modeling

Equivalent cross 
section

40

Parameters

• Matrix:

‐ Calculates Inductance matrix

‐ It is often useful to model the winding turns with an equivalent cross section, in order to avoid mesh issues and 
to reduce simulation time 

‐ In that case Matrix allows postprocessing where it is possible to insert the number of turns and define eventual 
groups and branches

‐ When grouping, the excitations are implicitly series connected each other
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Inductance Matrix Calculation

• Two types of inductance calculation:

‐ Apparent Inductance

• The slope of a line from the origin to the operating point. Apparent inductance gives the total flux linkage as a 
function of current. 

‐ Incremental (differential) Inductance

• The slope of the tangent to the curve at the operating point. Incremental inductance is the usual textbook 
definition. 

• Inductance calculation method can be selected through menu item

Maxwell 3D/2D → Design Settings→ Matrix Computation

Flux linkage vs. current 
different inductances

𝑳𝒂𝒑𝒑 =
𝜆

𝐼
𝑳𝒊𝒏𝒄𝒓 =

𝑑𝜆

𝑑𝐼
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Analysis Setup

• Solution Setup

‐ The solution setup defines the parameters used for solving the simulation

‐ A Solution Setup can be added from the menu Maxwell 3D/2D → Analysis Setup → Add Solution Setup

‐ General Tab

• Name: Setup name. Multiple setups can be present in the same design 

• Maximum Number of Passes: limit to number of adaptive passes

• Percent Error: Error goal for both Error Energy and Delta Energy

• Solve Fields Only: Ignores any defined parameters if checked

• Solve Matrix: option to calculate the matrix after the last solved pass or 
only if the solution converges

‐ Convergence Tab

• Refinement Per Pass: number of tetrahedral elements added at each 
pass as a percentage increment

• Minimum Number of Passes: minimum number of adaptive passes before 
solution stops

• Minimum Converged Passes: minimum number of converged adaptive 
passes before solution stops
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Analysis Setup

• Solution Setup

‐ Solver Tab

• Nonlinear Residual: error in finding operating points along B-H 
curve

• Enable Iterative Solver: Enables ICCG solvers (Direct is the default)

• Permeability Option: allows operating points either to be 
calculated from Nonlinear B-H curve or to use frozen permeabilities 
From Link (linked model must have the exact same geometry)

• Import Mesh: Allows the initial mesh to be imported from another 
solution – the linked solution must have the exact same geometry 
as the current simulation
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Variables and Parametric analysis

• Variables

‐ All the geometry dimensions, sources and in general most of the settings can be parametrized through suitable 
variables

‐ Variables can be either Local (Design) or Global (Project)

‐ Local variables are valid only inside the Design where they have been defined

‐ Global variables begin always with the $ symbol and are shared through all Designs belonging to the same 
Project

• Parametric analysis

‐ The Optimetrics module offers the possibility to sweep variables values and run a set of (even numerous) 
different simulations

‐ Parametric analysis is often used for model performances optimization or to study the influence of different 
parameters on devices performances.

‐ Parametric analysis ca be added through RMB on Optimetrics → Add → Parametric
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Postprocessing – Part 1

• Results Reports

‐ Maxwell calculates the fields distribution and then other 
quantities, like, e.g. forces, torques, inductances,  etc.

‐ Those quantities can be accessed from Project manager 
through a RMB on Results → Create Fields Report →
(select one report from the list)

‐ Results are displayed on a XY graph where the quantities 
on the two axis can be selected at own convenience

• Fields Overlays

‐ Selecting objects which are part of the model, it is 
possible to display the calculated field distribution, as 
well as the mesh

‐ Fields can be displayed using RMB on selected objects→
Fields→ (select one field from the list)
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Postprocessing – Part 1

• Results Reports examples

• Fields Overlays examples
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Summary

What have we learned in this lecture?

‐ Maxwell settings and GUI

‐ Material Properties

‐ Boundary Conditions

‐ Excitations

‐ Adaptive meshing

‐ Magnetostatic solver

‐ Parametric analysis

‐ Basic of postprocessing



APPENDIX: Geometries in 
Maxwell

48
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Maxwell Geometry

• Maxwell Geometry

• Ansys Maxwell uses primitives-based modeling technique where basic structure is created using Geometry 
Primitives and then Geometry operations are performed to achieve final object

• The underlying solid modeling technology used by Maxwell products is provided by ACIS geometric modeler. 
ACIS version 27.0 is used in Maxwell R18.0

• Geometry can also be created in Ansys Design Modeler and can be used in Maxwell through Ansys Workbench 
interface
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Geometry  Terminology

• Geometry Terminology

‐ Point: Independent point entity

‐ Vertex: Point entity that is a part of an Edge or Line object

‐ Line Object: Independent line entity

‐ Edge: Line entity which is part of either a sheet or a Face

‐ Sheet Objects: Independent surface entity 

‐ Face: Surface entity that is part of a Sheet or a Solid

‐ Solid Objects: Entities that have a definite volume

‐ Coordinate Systems: Default “Global”

‐ Planes: Default Global XY, YZ and XZ planes

Line

Vertex

Point

Edge

Sheet

Plane

Coordinate 
System

Face

Solid
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Geometry  UI operations

• Setting Visibility of the Object

• Visibility of the object in 3D Modeler window can be set from menu item View → Visibility or the toolbar

• Geometry Measurement

• Measurement command can be launched from the menu item Modeler → Measure

Measures position of cursor with reference to Current CS or last selected position
Measures length of an edge

Measures Area of a face

Measures Volume and Surface Area of an Object
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Geometry  Creation

• Geometry Creation from Primitives

• Geometrical entities can be created using primitives from the menu bar Draw

Line Objects

Sheet Objects

Solid Objects

Inputs

Start and End Points

Start, intermediate and end points

Coordinates of Three points  of arc or Center and two end points

X, Y Z Coordinates as a function of the variable “_t”

Coordinates of two diagonal points

Coordinates of center and major, minor radius

Coordinates of center and Radius

Coordinates of center, Radius and Number of sides

X, Y Z coordinates as a function of the variable “_u” and “_v”

Coordinates of two diagonal points of base and height

Coordinates of center of base and radius 

Coordinates of center of base, radius  and number of segments

Coordinates of center of Base, lower and higher radius and height

Coordinates of center and radius

Coordinates of Center, Inner and Outer radius

Sheet defining cross section, helix vector, pitch and turns

Sheet defining cross section, spiral vector, radius change and turns

Two points and parameters of the wire in parameter dialog



©2020 ANSYS, Inc. Unauthorized use, distribution, or duplication is prohibited.53

Geometry  Creation

• User Defined Primitives

• User defined primitives enable users to create and parameterize complex geometrical objects using inbuilt 
templates in Maxwell

• A User Defined Primitives can be added from the menu item Draw → User Defined Primitive

Note: Please refer Maxwell Help for more information on the User Defined Primitives
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Geometry Operations

• Creating Sheets from Lines

‐ Edge objects which form a closed loop can be used to create sheet object by selecting menu item 
Modeler → Surface → Cover Lines

‐ This operations can be set as default execution on creation of closed polylines by setting the option 
under Tools → Modeler Options → Automatically Cover Closed Polylines

• Creating Solids from Sheets

‐ In the same way as sheets, Solids can also be formed from sheets using various operations under 
Modeler → Surface 
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Geometry Operations

• Sweep Objects:
• Sweep command can be accessed from menu item Draw → Sweep

• Sweep Around Axis

− Inputs: Profile Sheet or Line body, X,Y or 
Z axis of active CS, Angle of Sweep and 
Draft details if needed 

• Sweep Along Vector
− Inputs: Profile Sheet or Line body, 

Sweep vector  and Draft details if 
needed 

• Sweep Along Path

− Inputs: Profile Sheet or Line Body, Path 
Line Body, Twist and Draft details if 
needed
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Geometry Manipulation

• Arrange Geometry

‐ Arrange Geometry can be initiated from menu item Edit → Arrange

• Move
− Translates geometry along 

the translation vector

• Rotate
− Rotates the 

geometry 
around selected 
axis of Work CS

• Mirror
− Mirrors geometry about a plane defined using 

Plane Normal

• Offset
− Scales the geometry about 

its Centroid. Applicable 
only for Solids.
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Geometry Manipulation

• Duplicate Geometry

‐ Duplicate Geometry can be initiated from menu item Edit → Duplicate

• Along Line
− Duplicates geometry along 

specified vector

• Around Axis
− Duplicates geometry around 

selected axis of Work CS

• Mirror
− Duplicates geometry about a 

plane using Plane Normal
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Boolean Operations

• Booleans

• Boolean operations can be launched from menu item Modeler → Boolean

• Unite
− Unites all selected bodies into 

single Body

• Intersect
− Gives Intersection of Selected 

Bodies

• Subtract
− Subtracts Tool 

Bodies from 
Blank Bodies

Without Clone Tool 
Objects

With Clone Tool 
Objects
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Boolean Operations

• Split

‐ Splits the Selected Geometry using XY, YZ or XZ plane of Active CS

Positive Side Negative Side Both

Keep fragments

Split entire selection Split objects crossing 
split plane

Split Objects
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Geometry Import

• Geometry Import in Maxwell

‐ Users can import models in Maxwell using neutral formats such as STEP(*.step, *.stp), IGES(*.iges, *.igs),  
Parasolid (*.x_t, *.x_b). After importing into Maxwell, the files are translated into native ACIS kernel 

‐ Maxwell can also import CAD file formats such as AutoCAD(*.dwg, *.dxf), CATIA(*.model, *.CATPart, 
*.CATProduct), Creo (*.prt*, *.asm), Unigraphics(*.prt). 
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Workshop 1.1 – Magnetostatic 2D analysis
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Workshop 1.2 – Magnetostatic 3D analysis

Current

Coil

Permanent Magnet

S

N

Magnetic Field Generated by the Coil
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