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Outline - Microstrip Bend Lumped Ports and Geometry Construction

This HFSS workshop starts with a microstrip transmission line with a right-angle bend built in the
geometry construction workshop.

The steps covered in this workshop:

1. Add Lumped Ports and an Open Region MicrostripBend6.aedt
2. Add a Solution Setup and Frequency Sweep MicrostripBend7.aedt
3. Simulate (Analyze) MicrostripBend7.aedt
4. View S-Parameters MicrostripBend7.aedt
5. View Field Plot MicrostripBend7.aedt
6. Animate Field MicrostripBend8.aedt

This workshop starts with MicrostripBend5.aedt. The ending HFSS project file name will be: MicrostripBend8.aedt.

Additional detailed information on geometry construction in the HFSS modeler is available in the Help document HFSS. pdf which
can be found in the HFSS online Help and in the installation directories in the Help/HFSS directory. RTMT - Read the manual too!
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Microstrip Bend Model Geometry Overview

MicrostripBend5.aedt has
the complete geometry and
20 mm no other simulation setup.

dielectric
material
FR-4

The magenta (pink) color indicates
that the object is selected.

perfect electrical conductor boundary
condition ground plane along the bottom
of the substrate
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Open AEDT Project MicrostripBend5.aedt

— In the Desktop tab of the Ribbon, click on the Open
button and select MicrostripBend5.aedt from WS5.1.

@ ANSYS Electronics Desktop
File Edit View Project Tools Window Help
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This can also be accessed from the pull-down menus by selecting : A ' Restore Archive
. M O O
File > Open. L ks
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HFSS Project Manager, 3D Modeler Tree, and 3D Modeler

Terminology clarification...

IPmJECt Manager [® | MicrostripBend7 - HFSSDesign1 { Modeler
=13 MicrostripBend7* —

; o Z
=-## HFSSDesignl (DrivenTerminal)* F @ Model 3D
= 5 Solids f
- 30 Components E
..... % Model =& copper Modeler
=-£F Boundaries ! FR4_epoxy
~EF PerfEl E! vacuum Tree
89 Excitations PrOJECt D CreateRegion
£ 1 Manager 53 Sheets Y
| @(j} Trace_T1 EIEl Lumped Post
- ® Trace_T2 E gOE;
~&F Hybrid Regions 0
----- BB Mesh Operations D Perfect E 3D MOdEIEf
=4 Analysis - Lines
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Select Port Rectangle and Add Two Lumped Ports

Project Draw Modeler HFSS [ | MicrostripBend5 - HFSSDesign1 - Modeler

¥) Undo | Select: Face hd =4 Model
e Make sure the Select 57 Solids & =
- mode is set to Face. 5-E3 Sheets !
----EI Perfect E
Model Simulation E||:| Unassianed
- (=EE)
~- Port? N
— In the 3D Modeler, select the Port1 rectangle, N
either from the 3D Modeler Tree or by clicking
on the Face on the geometry. _
=
— Right-click on selected Port1 and choose
Assign Excitation > Lumped Port... | PortName: 1
This can also be accessed from the pull-down menus by selecting HFSS > | Terminal Naming
Excitations > Assign > Lumped Port... i @ Use conductor name
. ) [ { llze port object name
In the Reference Conductors for Terminals dialog box that appears..... ;
_ ClICk Gnd for Use as Reference ' MOTE: Multiple reference conductars touching &

port must all be connected in the plane of the part.

— Click OK
— Repeat for second port.

Conductor Llse as Reference

Gnd
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Access Open Region Dialog Box from Ribbon Draw Tab

Project Manager

® | MicrostripBend5 - HFSSDesign1 - Modeler

=3 MicrostripBends* P

=5 HFSSDesign1 (Driven E@ r“l_‘;ﬂd'ﬂ
= H-00 Solids
~ggp 30 Components
..... ¢ @ Madel EI|:I Sheets Trace_Tl
=& Boundaries EIIZI Lumped Port
o perfel . &em Portf
£ Excitations . =~ Port2
B9 1 a3 Perfect E
@ Trace_T1 - Lines
Eﬂé} rece T2 m-le. Coordinate Systems
ﬁ Urihrid l?rnancii:c' Eﬂ@ PIaHES
With two lumped ports in place, the next step is to Help Create Region
create at open region. & Pan @\ Fit Al 9 o m@® |\ v
— From the Draw tab in the Ribbon, click on Open - Rotate v @ Fit Selected f§ Q @Aa|L L
Region to bring up the Region dialog box. @ orient - me RO L A
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Specify Region Dialog to Percentage Offset

Region X Region x
TUNIEE @ e e Padding Data: ( Pad all directions similarly
I (" Pad individual directions I
. (@ Pad individual directions
(" Transverse padding
(" Transverse padding
Directi0n| Padding type | Value |Units|
Al |Percentage Offset 0 Direction Padding type ‘ Value ‘Units|

+X | Percentage Offset 20
-X  Percentage Offset 20
+Y  Percentage Offset 20
-¥  Percentage Offset 20
+Z  Percentage Offset 500
-Z  Percentage Offset 3

[ sSave as default

— When the Region dialog box appears,

select Pad Individual Directions
— Fill in the values: 20% for +X, -X, +Y, -Y
— For -Z (bottom) 5%
— For +Z: 500 %
— Click OK
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Assign Radiation Boundary to Region - MicrostripBend6.aedt

— Select the Region, either in the 3D Modeler Tree
(under vacuum) or in the 3D Modeler.

— Right click and choose Assign Boundary > Radiation.

— When the Radiation Boundary dialog box appears, Name: |Rad!
the default name Rad1 can be used.

— Click OK to close the Radiation Boundary dialog box.
— Select File > Save As Mictrostripbend6.aedt

Qlation coundar

icrostrip - igni - eler
' | MicrostripBend5 - HFSSDesign1 - Model
=3 MicrostripBends* e
i - —_— B4 Model
--#% HFSSDesignl (Driven _
E: 3D Components E"} Solids
..... b Model =& copper
[—]E‘ Boundaries 5 FR4_epoxy
- EF PerfEl =& vacuum
E-89 Excitations 9 CreateRegion
E@ L -3 Sheets
E@{j} Trace_T1 E|IZI Lumped Port
- @ Trace_T2 :I Port1
~&F Hybrid Regions &-E Port2
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Create a Solution Setup - 10 GHz - Delta S 0.02

— In the Ribbon, under the Simulation tab, select Setup >
Advanced.

— When the Driven Solution Setup dialog box appears, in
the General tab, specify

* Frequency 10 GHz
* Maximum Number of Passes: 10
* Maximum Delta S: 0.02

— Click OK

... which brings up the Edit Frequency Sweep dialog box.

----- B Mesh Operations

----- g

~{[& Optimetri —
----- Results "7 Add Solution Setup...

Solution Setup is also accessible from the
Project Manager by right-clicking on
Analysis and choosing Add Solution Setup.

ANSYS Electronics Desktop - MicrostripBend6 - HFSSDesign
File Edit View Project Draw_Modeler HFSS Tools Wi

B 2Bl T

Sawve A Paste Setup Optimetrics . Valic

-

Desktop View Draw Model Simulation Results

Project Manager
Elm MicrostripBend6

3 P Add Solution Setup

KOS Add a new solution setup.

Driven Solution Setup

lGeneraI 'Options I Advanced] Hybridl Expression Cache Derivatives] Defaultsl

Setup Name |Setup'|

[+ Enabled [ Solve Ports Only

Adaptive Solutions

Solution Frequency: i® Single (" Multi-Frequencies i Broadband
Frequency 10 GHz ﬂ
pr—
Maximum Number of Passes 10
pr—
(@ Maximum Delta S 0.02

( Use Matrix Convergence
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Add a Frequency Sweep from 0 to 10 GHz in 0.1 GHz Steps

— If the Edit Frequency Sweep window doesn't appear ...

©)
— In the Project Manager, under Analysis, select the File Edit View Project Draw Modeler HFSS Tools Wi
new Setupl. ] I “ut ¥) Undo qu: I‘; ﬁ'? N
— In the Ribbon, under the Simulation tab, select Sweep ' “opy (% Redo MRS el _
. ) Save £ Paste ~ ... Setup |Sweep | Optimetrics Valic
— When the Edit Frequency Sweep dialog box appears, | o v
in the General tab, specify: Desktop  View  Draw  Model | |Simulation | Results
* Sweep Type: Interpolating
* Frequency Setup Type: Distribution: Linear Step Edit Frequency Sweep
e Start 0.0 GHz General Interpnlation] Def‘aults]
i End: 10 GHZ Sweep Name: |Sweep [v Enabled
Y o
Step' 0'1 GHZ Sweep Type: |Interp0|ating ﬂ
- CIICk OK Frequency Sweeps [1001 points defined]
If a message appears about using causal materials, e p— =
C“Ck OK gl Linear Step
— Click OK

to close the Edit Frequency Sweep dialog box.

Edit Frequency Sweep is also accessible from the
Project Manager, under Analysis by right-clicking
on Setupl and choosing Add Frequency Sweep.
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Set Causal Materials in HFSS > Design Settings

To address this recommendation, we'll set
HFSS to Automatically use causal materials.

— Select HFSS > Design Settings to bring up the
HFSS Design Settings tab dialog box.

— Select Lossy Dielectrics tab.

— Check the box for Automatically use causal
materials.

— Click OK to close the HFSS Design Settings
dialog box.

For more information see HFSS.pdf, HFSS
Technical Notes > Introduction to Causality Issues
for Simulations.

AMNSYS Electronics Desktop *

For broadband frequency models it is recommended to set

5 'Automatically use causal materials' in the HFSS Design Settings
for Lossy Dielectrics. See 'Design Settings for HFSS' in the help
for more information.

OK
HFS5 Design Settings
Walidations S Parameters ] Export S Parameters
Set Material Override [ Lossy Dielectrics l DC Extrapolation

This option will cause objects with constant material permittivity greater than one and dielectric
loss tangent greater than zero to be treated as frequency dependent

Their actual permittivity and conductivity will be determined by the Djordjevic-Sarkar algorithm,
and the loss tangent will be zero.

[v Automatically use causal materials

[ Save as default
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Save As MicrostripBend7.aedt, Validate, and Simulate

)
— Click the Validate green check mark in the ribbon (with file Edit View Project Draw Modeler HFS
Simulation chosen) to validate the project. e
= I_f '!.
— Select File > Save As and save project renaming file as: Ve [ Paste sep Swep Optimetrics [ Validate pnavze

MinOStripBend7.aEdt Desktop View Draw Model l Simulation | Results Automat

Keep all HFSS workshop simulation files; future workshops
continue with these files.

Validation Check: MicrostripBend7 - HFSSDesign1 *

' Design Settings
@? HFSSDesign & 30 Model

— Click on Analyze All in the ribbon to start the HFSS 4 s Etoions
Simulation. Yalidation Check completed. jg;?:jt?if:tup
-« Radiation
The Validation Check and Analyze All operations are also available
from the HFSS pull-down at the top of the graphical user interface | [oes |
(GUI).
: : . o @
— Save MicrostripBend7.aedt when the simulation finishes. file Edit View Project Draw Modeler HFS dow Helc
T I_f J *h
Save _'d.Paste Setup Sweep Ophrietrlcs Validate] Analyze

Desktop View Draw Model Results Automat

Click on Show Messages and in the bottom right of the GUI in order to see the simulation progress.
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Bring Up New Report Dialog Box for Plotting S-Parameters

— In the Rlpbon, in the Results tab, click ) | X Delote Al Reports X
on Terminal Solution Data Report and 5 |BEH \J W
SeleCt ZD. Output Modal Solution Fields Emission Test

¥ Variables B Data Report ™ Report™  Report™

— When the Report dialog box appears, Model  Simulation | Results | Auto @ B
select the reflection and transmission - ] & e
S_pa rameters for portl/Tl ] MicrostripBend] Stacked Polar Data Table

] lerminal)* E@ MOdEI_ | 2D ™ -~
...continued on next page.... - B4/ Solids ( S —r
‘ s Coppe _ _.-/ T i
. -4 FR4 ey Smith Chart 3D 3D Polar 2D Contour

The New Report - New Traces dialog box is also accessible from the Project Manager. Right-click on Results
and select under A Create Terminal Solution Data Report > Rectangular Plot.

OR

From the top pull downs, select HFSS > Results > Create Terminal Solution Data Report > Rectangular Plot.
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Plot MicrostripBend7 S-Parameter Simulation Results

In the New Report dialog box, Trace tab set:

Report: MicrostripBend7 - HFSSDesign1 - New Report - New Trace(s) >
- SOIUt’on: Setupl: Sweep Silier Trace Families] Families Display]
— Domain: Sweep Solution: |Setup1 : Sweep ﬂ Primary Sweep: |Freq ﬂ """” J
— Primary Sweep: Freq e B I % @ oot [Fre -]
. . ¥ dB(St(Trace_T1,Trace_T1)); dB{St(Trace_T1,Trace_T2)) I
— Category: Terminal S-Parameter Function...
— Quantity: Category: Quantity:| ﬂ Function:
dB(St(Trace_T1,Trace_T1)); dB(St(Trace_T1,Trace_T2)) Outout voriables e e e
. Troce 12 trace. 11 ang_deg vl
- Terminal ¥ Parameter = = ang_rad
Use Ctrl-D to multiple select traces. St(Trace T2 Trace_T2)
Terminal Z Parameter - - arg
. Terminal VSWR _d
— Function: dB Terminal Port Zo cang_deg_val
Group Delay cang_rad
— Click on New Report. boagn M
dB20normalize
— Click on Close. p
Update Report mag i
normalize
[v Real time re
Output Variables... | Options... ‘ Mew Report | | Close
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View MicrostripBend7 S-Parameter Simulation Results

[® | MicrostripBend7 - HFSSDesign1 - Terminal S Parameter Plot 1 | — ” (5] ”i&|

As we Ppr.eCt’ the Terminal S Parameter Plot 1 HFSSDesign1 4
transmission S-parameter 0.00 S

magnitude

dB(St(Trace_T1,Trace_T2)) 20.00 1 ]

(like an S4;) is near 100% and

decreases as frequency goes 4000 ]

Curve Info
up. 1

— dB(St(Trace T1,Trace T1))
Setup1 : Sweep

The reflection S-parameter 5~ -60.00 - Setua] aieace_T. Trace_12))
dB(St(Trace_T1,Trace_T1)) ]
(like an Sq;) is lower and -80.00
increases as frequency goes ]
up. -100.00 —
O T ke T ek ebo . sho T 0o
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Return to the Modeler View

— From our view of the S-parameters, we want to return to the Modeler. This can be done by either:

— Double-clicking on the design name HFSSDesign1 (DrivenTerminal)

in the Project Manager: = MicrostripBend7*

=% HFSSDesign1 (DrivenTerminal)*
: E 3D Components

OR g Model

— Selecting Window > MicrostripBend 7 - HFSSDesign1 - Modeler

Window Help
New Window
Cascade Ctrl+0
Tile Horizontally Ctrl+1
Tile Vertically Ctrl+2
Arrange Icons
Close All

1 MicrostripBend7 - HFS5Design1 - Modeler
+ 2 MicrostripBend? - HF5SDesign1 - Terminal 5 Parameter Plot 1
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Bring Up the Create Field Plot Dialog Box

=g Model
=& Solids
ES copper

=S¥ FR4_er
=--&% vacuun
=3 Sheets
=0 Lumpe
=3 Perfect
5=
Y

H-"™ Lines

=& Planes
B¢ Lists

o E

=

@12, Coordinate Sy

Expand All
Collapse All

Select

Edit

Group

Create 3D Component...
Assign Material...

View

Properties...

Create Array ...

Create Open Region ...

Update Open Region Padding...

Assign Boundary
Assign Excitation
Assign Hybrid

Assign Mesh Operation
Plot Fields

Plot Mesh...

Plot VRT...

WOOW W W

E >

H >

J > Mag_Jsurf

Q > ComplexMag_Jsurf
Other > Vector_Jsurf
Radiation Field... Mag_Jvol

ComplexMag_Jvol
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— Select both the Trace and the Gnd
in the Model tree. Use Ctrl-D for
multiple select.

— Right click on either of them (or in
the Project Manager on Field
Overlays)

— Select Plot Fields > J > MagJsurf to
bring up the Create Field Plot
dialog box.
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Access Create Field Plot Dialog Box

In the Create Field Plot dialog box, verify

or select:

— Solution: Setupl: LastAdaptive
— Freq 10GHz

— Quantity Mag_Jsurf

— Click Done.

Mag_Jsurf Linear scale

Create Field Plot

[ Specify Mame |N1Elg_J5urf1

[ Specify Folder |J5urf J

Design: HF350Designl
Cantax

Solutian: |Setup1 - LastAdaptive ﬂ

Field Type: |Fields ~|

Intrinsic %ariakhles

Freq [10GHz

=]
=]

Sawve As Default |

Figlds Calculator ...

Category: |Standard

Cluantity

=

In“%olurme

hag_E ”~
Complextag_E

Yector E

hag_H

Complextdag_H

Yector H

Mag_ Jsurf
Complextag_Jsur
Yector_Jsurf

bag_ ol
Complextag_Jval
Yector_ ol
kag_Jm
Complextdag_Jm
Yector_Jm

ABS_0

SmoathCl v

AT T

Dione

Cancel

Box1
Trace
Fegion
AllDkjects

[ Floton sudace only

[ Streamline
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In Attributes Scale Tab Set Scale to Log

Isurf [A/m]

—_ . [MicrostripBend7] HFS5Design1 -- Jsurf X
In the 3D.Modeler, P In Jsurf tab dialog box: |
dOUbIe'Cth on the b 523E+E0 Colormap Scale Marker{ArrowI Deformation Scale' Plots |
color scale to bring weezzewe — Select the Scale tab.

up the ,Isurf tab 2. B7GEE+0

1, 3943E+29 — Near the mlddle, click
i . - . MNum. Division |15 Saveasdefaultl
dialog box. o 2os6t a1 on the Log radio button

: zg;;g:gi (instead of [_inear)_ @ Auto Min: | 2 6044E-02
1.9856E-81 .
1, 2799E-@1 _ Cllck Close. " Use Limits Max: I 1.0202E-+01

5. 5OUBZE-BZ
5. 7735E-@2 " Specify Values Scale Values... |
3.8777E-02 ,

2, BEYYE-BZ [~ dB Units IA_per_m vI

" Linear @ Log

—Auto Scale Options

[ Limit Max/Min precision to |4 v l digits

— MNumber Format

Type: |scientfic v | Width: |12

Precision: |4

[v Realtime mode Apply | Close |

Mag_Jsurf Log scale
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Animate Fields and Save As MicrostripBend8.aedt

— In the Project Manager, right-click on
Field Overlays and select Animate.

— In the Select Animation menu, click OK.

— The Animation player comes up and the
field animation starts playing.

— When finished, click the square stop
button and the X to close the Animation
player.

— Save As MicrostripBend8.aedt when
the simulation finishes.

Select Animation
Animationl (Swept variable Phase)
MNew..
Delete
Animation: Animation — X
N :
| :
stop play :
< A =] p] »]
Speed
Frame: 10, Phase = 90deqg B
Close
Label:
Background: Fant [v Show
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End of Pre




