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Outline - Busbar 100 MHz Simulation Workshop

The goal of this workshop is to set up a Q3D simulation and learn the workflc

List of what this workshop will do:

* Invoke AEDT and open archived Q3D example EMCDbarS0.aedtz.
e Set up Nets - EMCDbarS1

* Define sources and sinks - EMCDbarS1

* Create a single-frequency analysis solution setup.

e Simulate at 100 MHz - EMCDbarS2

* Plot a Data Table of DC and AC inductance

* Add a frequency sweep to the solution setup - EMCDbarS3

* Resimulate

* Plot DC and AC inductance over frequency - EMCDbarS3
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Launch AEDT - Open Q3D Project EMCDbarS0.aedtz

Open Q3D and the archived example project EMCDbarS0.aedtz ...

* To access Q3D, click the Microsoft Start button, select B Ansys M suite
Programs > ANSYS EM Suite 20XXRY > ANSYS Electronics Desktop

A new Projectl appears under the Project Manager.

!d ANSYS Electronics Desktop

In the Ribbon, in the Desktop tab, select the icon: Restore Archive

Browse to the workshop directory and click on EMCDbarS0.aedtz

ile Edit e Project Tools dc Help
z refers to archive N ~ ~ ﬂ I Tl & [ Save Archive
e Select Open . ' A W . " | # Restore Archive
Mew Open Open Save Save Close ‘—
* When the browser changes to Project File Restore Location, Save the Examples As
file EMCDbarS0.aedtz in a working directory. Desktop  View  Simulation  Automation
Project Manager &, X
= Project1
% Archive to Restore X
Lookin: | = Q3D_SIGS_WS22_EMCDBarS ~| e ®&@ckE
2 Name Type
: #\ EMCDBarS0.aedtz ANSYS Electronics Desktop Archive File
Quick access
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Q3D Project EMCDbarS0.aedt

There are no Boundaries nor Nets set up. There are no Analysis nor Results setups.

Project Manager 1 X #E5-% Model
=[] EMCDBarS0 . B Solids
=& 3barsD 5 t! copper
' & 3D Components #--&” Barl
@ Model . B Bar2
¥ Boundaries : . @& Bar3
3. Nets =28 diel
i f Mesh . #-&’ Diel_Substrate
T E::I E;j;?gx:ltm =l Coordinate Systems
& Analysis 4%, Global
@ Optimetrics 1' @ Planes
Results =€ Lists
_ W Field Overlays
+-- (1 Definitions
3D Modeler Tree
... also called
Project Manager History Tree 3D Modeler
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Units mm and Copper Material - EMCDBarS1.aedt

* In the Ribbon, with the Draw tab selected, click on the

icpndfor Units to bring up the Set Model Units &~ v U@ Measure v I Grid *H @
window.

== Ruler XY il |"_—|
* Verify that units are mm and close the window. L.+ Units D - G

* |n the 3D Modeler, click on Bar3, the shortest bar on
the right, to select it.

X

.;'.i Set Model Units

Properties 1 X
Selectunits: X~ |

Name Value Unit |Eva...
Name Bar3 | Rescale to new units
Matenal "copper” "co..
Orientation Global oK Cancel
Model 2
Group Model
Display Wirefr.. . . .
Material Appe |E * In the lower left, in the Properties window,
Color — verify the copper material on Bar3.
Transparent 03 | * Save project to EMCDBarS1.aedt
Attnbute
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Changing Bar3 Material to Aluminum - EMCDBarS1.aedt

* Still in Properties, choose “copper” in the Material row and
choose Edit... to bring up a Select Definition window. Properties: EMCDBarS1 - 3barsD - Modeler X

(Another way to bring up this same Select Definition window Atiibute
is to double-click in the 3D Modeler Tree on Bar3.)

Name | Value ‘ Unit |Eva|uated ‘ Description ‘Head-only‘
* In the Select Definition window, scroll or search for aluminum. [ [Name Bard r
W Vool [fcopperBBR  copper | | M |
Select Definition X | |Orientation  |Edit. [
Model " "
Materials ] Material Filters — a aluminum P
roup Dp
Search Paramet o . "diel"
S::Eh b:rri;nm:rs Search Criteria Librares | Show Project definitions [ Select all libraries - Display Wiref. "vacuum" ’_
| * by Name ¢ by Property | |[sys] Materials Material App... 1 [
Relative Pemittivity J = Color |:I [_
Transparent 0.3 [
. o Relative Relative B~
’/ = —E L Permittivity Pemeability Cond
air SysLibrary Materials 1.0006 1.0000004 0 [ Show Hidden
- AlZ2_03 ceramic SysLibrary Materials 5.8 1 0
Al_N SysLibrary Materials 28 1 0
N alumina_592pct SysLibrary Materials 52 1 0 0K | Cancel | Apply ‘
alumina 96pct S;"lel:urar}.I Materals 0
: SysLibrary Materials 1.000021 36000000sie . .
| [auminum_no2_EC Sylby | Materals 1 1000021 330000005  Select aluminum and press OK to close the window.
Adon 25FR {m) SysLibrary Materials 358 1 0
[ [don 25N g Splbray [Matetels _[338 1 0 (If you were using the double-click method for
Adon ADT000 ftm) SysLibrary Materials 10.2 1 0 v . ) .
gy — S - P— properties, you’ll have to press OK again to close the
View/Edit Materials... Add Material... Clone Material(s) Remove Material(s) | Export to Library... | WI n d OW. )

QK | Cancel | Help |
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Defining Nets - EMCDBarS1.aedt

When the design geometry and all the materials are properly set, you can define Nets:
* In the Property Manager, right-click on Nets and select Auto Identify Nets.
This project already has 3 conducting structures, so when we Auto Identify Nets, 3 Nets will appear.

Project Manager Project Manager 1 X
= EMmcDBars1 =] EMCDBars1
=& 3barsD SRS 3‘.barsl}
é 3D Components & 3D Components
._'(\ib Model &T} Model
&¥ Boundaries ¥ Boundaries
R et ” =.t. Nets
Em\ Auto Identify Nets ;
B Mes : ota Barl Bar2 i
#[H] Red Assign Net - aba Bar2 are 1s
& Ana Reprioritize Net Type... ' *%_ Bar3 selected.
& opti Assign Terminals From List... B8 Mesh
Resl  Assign Excitation =-{H] Reduce Matrix
o ~-[H] original
. J¥ Analysis
Reminder: If we only want to solve for { optimetrics
capacitance, we don't need to define Results
Sources and Sinks. - I Field Overlays
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Selecting Faces for Terminals - EMCDBarS1.aedt

In this next section, we assign a current Source on one side of each

bar and a current Sink on the other side of each bar. Terminals can ¢) Undo Select:|Object | ¥ @
be directly applied to geometry faces. ® sel submodel ;l %
i Delet Object
* Enter Face selection mode one of three ways: 8 Delets = -
ace
- In the Ribbon, in the Draw tab, change the Draw  Modk == Results
Select option to Face.
- In the 3D Modeler window, right-click and
choose Selection Mode > Faces o -
- Press F ... the hot key for invoking Faces TP T Tr—
select mode. Select Objects > Submodel: ,
/ Extend Selection > & Objects (@)
Go to Histc Faces F |
- Measure > Edges £
Vertices '
Additional information: Q3D offers a boundary _ il /
. > . .
condition called Thin Conductor. This boundary can S Multi Mode Settings... 4

click the edge and apply a Terminal to the edge. Create 3D Component..

be applied to a sheet. If this is done, then you can 7 Group
V4

/ :T'_ ace wit 2D
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Adding Terminals to Net Faces - Sourcel

* In Face Select mode, click the Barl face, (on the left-
hand side), at the front of the model looking towards
negative X.

Select Objects >
Extend Selection >
Go to History

Z Measure >
View >
Edit >
Group >

Create 3D Component...

Assign Boundary >
o\ Auto Identify Nets
Assign Net ¢
Assign Excitation >| @ Source..
Assign Mesh Operation > | a Sink..
T Assign Reduce Matrix > E

* In the 3D Modeler, right-click and select Assign
Excitation > Source, which brings up a Source dialog
box.

(An alternative is pull-down menu Q3D Extractor >
Nets > Assign Excitation.)

* In the Source dialog box, keep the default Source 1
and click on OK.
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Assigning Terminals to All Nets - EMCDBarS1

* Repeat this process of assigning two more Sources to the front.
 Assign Sinks to the back faces of all three bars.
* Save project EMCDBarS1.

For the Sinks, that are on the back of
the geometry, you can click where the
desired face is, and when the top faces
gets selected, click the B button (Next
Behind) to select the desired face.

See Appendix at the end for other
useful hot keys.
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Adding a Solution Setup - EMCDBarS1

Project Manager i

=] EemcpBars1*
=& 3barsD*
é 3D Components
&5 Model
¥ Boundaries
=%, Nets
=-.t. Barl
-8, Sinkl
. - Sourcel
2. Bar2
o Sink2
- D Source2
=l--%, Bar3
-8 Sink3
@ Source3
B8 Mesh
= [ii] Reduce Matrix
~-[H] original
JefAnalysis
{® optimets Paste
Results | (» Add Solution Setup...
) Iy Field Ov Tist_
#--|_] Definitions

In the Project Manager, right-
click on Analysis and select Add
Solution Setup ... to bring up the
Solve Setup dialog box.

In the Solve Setup window, in
the General tab, set:

Solution Frequency: 100 MHz
Leave all the boxes checked
Save project EMCDBarS1.

Another way to access Solution Setup is from the top pull downs:
Q3D Extractor -> Analysis Setup -> Add Solution Setup.

Solve Setup
General \ICG | DCRL | ACRL | Expression Cache | Defaults |
Name: Setup1) [v Enabled
Solution Frequency: |1[}0 |MH7_ ﬂ

Solution Selection
v Capacitance/Conductance
v DC (@ Resistance/Inductance
(" Resistance Only

[v AC Resistance/Inductance

[T Save fields

Use Defaults

HPC and Analysis Options.

Cancel

o]
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Validate and Analyze at 100 MHz - EMCDBarS2

- EMCDBarS2 - 3barsD - 3D Modeler - [EMCDBarS2 - 3barsD -

» Save the project as EMCDBarS2. Modeler Q3D Extractor Tools Window Help
* In the Ribbon, in the Simulation tab, click the icon for Validate with 7 I_ \/ D
S V5 © (or By =
the green CheCk mark Mesh  Setup Sweep Optimetrics] Validate JAnalyze HPC
eedback - All Options
e Make sure that the Progress and Message Manager windows are T e
showing. If not, click the icons at the bottom of the interface to
Open thOSG W|ndOWS Validation Check: EMCDBarS2 - 3barsD X
« Design Settings
¥ Show0Messages | ~— Show Progress o e M-
_— « Mesh Operations
Walidation Check completed. o Reduce Matrix
« Just to the right of Validate, click on Analyze All to start the Q3D ¥ Optnetics
simulation.
The Validation Check and Analyze All operations are also available from the |
Q3D Extractor pull-down at the top of the graphical user interface (GUI).
* Watch the Progress Window and the Message Manager to see - EMCDBarS2 - 3barsD - 3D Modeler - [EMCDBarS2 - 3barsD ;
When the SimUIation ﬁniSheS Modeler Q3D Extractor Tools Window Help
. . . . e | il £B
Keep all Q3D workshop simulation files; future workshops may continue @ I_f w/ EEE!
with these files or refer to results. N;gh ) Setup Sweep Optimetrics Validate Anilﬁrze OHF_’C
eedbac v ptions
* When the simulation finishes, save the project again. Simulation  Results  Automation
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Plot Single Frequency Inductance Results - EMCDBarS2.aedt

* Plotting DC Inductance Data Table...

- In the Project Manager, right-click Results
Select Create Matrix Report->Data Table
Under Category, select DCL Matrix
Click DCL(barl1:Sourcel,barl:Sourcel)

Press New Report (... and leave the dialog open)

¥ Boundaries
&%, Nets
B Mesh

= [H] Reduce

i El:l Oric

=& Analysi

S Sett g

&l optime
3] Resuts
T Field O

b

Paste

Create Matrix Report
Create Report From File...

2 Delete All Reports

Report Templates

I‘ Ii & Bar3
=99 diel

Ctrl+V  jinate Syste

> Rectangular Plot
Rectangular Stacked Plot
Data Table
3D Rectangular Plot
Rectangular Contour Plot

* Plotting AC Inductance Data Table...

Still in the Report menu window ...
Under Category, select ACL Matrix
Click ACL(bar1:Sourcel,barl:Sourcel)
Press Add Trace

* Click Close to close the Report dialog box.
e Save the project EMCDBarS2.

Report: EMCDBarS2 - 3barsD - New Report - New Trace(s)

Context
Solution: ISetup1 : LastAdaptive :J
Matrix: IOriginaI LJ

Update Report

[V Real time

Output Variables... ] Options... 1

3

Trace I Families | Families Display |

Primary Sweep: |Freq LI IA” J

X: v Default I Fre J
. ( : g ) Range

y: .DCL.\Barl.Sourcel,Barl.bourcel) Function...

Category: Quantity: I L] Function:

Variables A DCL(Barl:Sourcel,Barl:Sourcel) IS M
Output Variables DCL(Bar2:Source2,Bar1:Sourcel) abs

C Matrix DCL(Bar3:Source3,Bar1:Sourcel) acosh

G Matrix - DCL(Bar1:Sourcel,Bar2:Source2) s

DCL Matrix i ang_deg

DCR Matrix DCL(Bar2:Source2,Bar2:Source2) ang_deg_val

ACL Matrix DCL(Bar3:Source3,Bar2:Source2) ang_rad—

ACR Matrix DCL(Bar1:Sourcel,Bar3:Source3) ara ¥
Design v DCL(Bar2:Source2,Bar3:Source3) Vv £ >

New Report | |

| Close
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Comparing DC Inductance to AC Inductance - EMCDBarS2.aedt

The DC inductance is 33 nH, while the AC inductance is 30.6 nH for the self-inductance of Net Barl.

~ =

® | EMCDBarS2 - 3barsD - DCL Matrix Table 1 =N
DCL Matrix Table 1 3barsD ANSYS
Freq [MHZ] DCL(Bar1:Source1,Bar1:Source1) [nH] ACL(Bar1:Source1,Bar1:Source1) [nH]
9 Setup1 : LastAdaptive Setup1 : LastAdaptive
1 100.000000 33.052846 30.601840

Why?

- If we think of current traveling through a wire at DC, we would see that current flows on the surface and inside of
the wire. Current density would be uniform on the cross section of the wire.

- At higher frequencies, current travels mostly on the surface of the conductor, which is realized in the skin effect.

- This leads directly to a reduction in inductance as the oscillations of a wave increase in frequency. (The inductance
around a wire decreases as the radius of the wire increases. Increase in frequency moves current to the outer edges
of a conductor. If we consider this similar to having a larger wire, then we expect the inductance to go down as
frequency goes up.)
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Add Frequency Sweep and Resimulate - EMCDBarS3

* Save the project to EMCDBarS3. Eﬁjj“::m:m :
* In the Project Manager, expand Analysis. T g e woonents
* Right-click on Setupl and select Add Frequency Sweep... Bose

to bring up the Edit Frequency Sweep window. o tets Uy Copy
* Set Sweep Name: to EMCD100M THERe]  Rename
* Set Sweep Type to Interpolating T dee X Eelerert |
* For the first Frequency Sweep line 1 set: Loy Shemet pisale Seup

- Distribution: Linear Count o oo GGG e

- Start: OHz End:OHz  Points: 1 it Frequency Sweep o B Smition <
* Click Add Below to get a second line General | Defauts
* For the second Frequency Sweep line 2 set: SweepName:  [EMCDI00M ¥ Enabled

- Distribution: Log Scale SweepType:  [Discrete =

- Start: 1Hz End: 100MHz Points: 10 Frequeney Sweeps [52 ponts cefnec]
* Click OK to close the Edit Frequency Sweep window. J treor coe - -

2 |Log Scale 1Hz 100MHz Samples 10

* Save the project.
* Click on Analyze to resimulate the project.
* Save the project again when the simulation ends.

Add Above Add Below Delete Selection Preview ...

3D Fields Save Options
[ Save CG Fields (All Frequencies)
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Plotting Inductance Over Frequency - EMCDBarS3

In the Ribbon, with the Results tab selected, click on Modeler Q3D Extractor Tools Window Help

the icon for Matrix Report and select 2D to bring up [ Delete All Reports [ [ .

the Report dialog window.

* In the Report window first plot DC Inductance Output Matrix | Solution
Variables Report¥] Data
- Under Category, select DCL Matrix _ ,
) Simulation Results Automation
- Click DCL(bar1:Sourcel,bar1:Sourcel)
- Click New Report ... keep the window open B Report: EMCDBarS3 - 3barsD - DCL Matrix Plot 2 - DCL(Bar1:Source1,Bar1:Source1) b6 1
* Next plot AC Inductance on the same plot Context Trace | Families | Families Display |
- Under Category select ACL Matrix souton: |setupt :EMDI0M | | iy sweep: [Freg <] [ =
- Click ACL(bar1:Sourcel,barl:Sourcel) bk e gl b | HE o B
- C||Ck Add Trace y: ’ACL(Barl:Sourcel,Barl:Sourcel) E::gt?on
* Click Close to close the Report window.
Category: Quantity: l L] Function:
Variables | <none>____ NS
Output Variables ACL(Bar2:Source2,Barl:Sourcel) abs
C Matrix ACL(Bar3:Source3,Barl:Sourcel) ac0s
cha,;n)t( ACL(Barl:Sourcel,Bar2:Source2) acosf:j
DC,;( Maatr:; ACL(Bar2:Source2,Bar2:Source2) :gg_dzg val
ACL(Bar3:Source3,Bar2:Source2) : ~
Update Report ACL(Bar1:Sourcel,Bar3:Source3) :?c? B
[v' Real time Design ACL(Bar2:Source2,Bar3:Source3) Vv < >
Output Variables... ‘ Options... ‘ New Report Apply Trace I Add Trace ‘ Close
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Initial Plot - Change X Axis Scalling to Log

» | EMCDBarS3 - 3barsD - DCL Matrix Plot 1 =N =R %"
DCL Matrix Plot 1 3parsD ANSYS
33.50 T |
1 Properties: EMCDBarS3 - 3barsD X
33.00
Cartesian | General | Grid | Header | Legend | X Axis | X Scaling ‘Y1 Axis | Y1 Scaling |
3250 .
] Name ‘ Value | Unit |Eva|uated V‘ Description
Curve Info — .
T Axis Scaling Linear
E.1200 - — DCL(Bar1:Source1,Bar1:Source1) — _
< Setup1 : EMCD100M Specify Min Linear
i
. ACL(Bar1:Source1,Bar1:Source1) —_ " LOg
31.50 Setup1 : EMCD100M | |Specify Max I
Max 100 MHz
2100 | |Specify Spacing [
Spacing 10 MHz
Minor Tick Divs 5
30.50 w . . ' T T ' \ T ' ' | ' T ' I Manual Units
0.00 20.00 40.00 60.00 80.00 —
Freq [MHz] _Aulo Units v
Units MHz
L. . Infinity Visualization
* In the initial plot of DCL and ACL, double-click the X " IMan Infinitv Mode — v
. 4 >
axis where the numbers appear
* Click the X Scaling tab L
* Change Axis Scaling to Log
OK Cancel
* Press OK |
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Final DCL & ACL Plot versus Frequency

As discussed with the single frequency simulation, the inductance goes down as frequency goes up.

# | EMCDBarS3 - 3barsD - DCL Matrix Plot 1 F=mrE "
DCL Matrix Plot 1 3parsD ANSYS
33.50
33.00
32.50
_ ] Curve Info
£32_00 N — DCL(Bar1:Source1,Bar1:Source1)
- . Setup1: EMCD100M
> 4
] ACL(Bar1:Source1,Bar1:Source1)
31.50 ] Setup1: EMCD100M
31.00
30_50 T T ||||||| T T ||||||| I T ||||||| I I ||||||| T T ||||||| T U ||||||| T T ||||||| T T mTrrrrT
1.00E-06 1.00E-05 1.00E-04 1.00E-03 1.00E-02 1.00E-01 1.00E+00 1.00E+01 1.00E+02
Freq [MHz]

©2020 ANSYS, Inc. Unauthorized use, distribution, or duplication is prohibited. \nsys



Appendix

Ansys



Electronics Desktop 3D Model Editor Keyboard Shortcuts

General Shortcuts 3D Modeller Shortcuts

* F1:Help * B: Select face/object behind current selection * CTRL + Left Mouse Click: Shifts the local
* F1 + Shift: Context help « F: Face select mode coordinate .

* F4 + CTRL: Close window system temporarily

O: Object select mode

* SHIFT + Left Mouse Button: Drag
* Hold X: Curser movement restricted

* CTRL + C: Copy

* CTRL + N: New project to x direction * Alt + Left Mouse Button: Rotate model
* CTRL + O: Open... « Hold Y: Curser movement restricted * Alt + SHIFT + Left Mouse Button: Zoom in /
* CTRL + S: Save to y direction out . .
* CTRL + P: Print... * Hold Z: Curser movement restricted * F3:Switch to point entry mode
« CTRL + V: Paste to z direction (i-e. draw objects by mouse)
* CTRL + X: Cut * CTRL + A: Select all visible objects * F4: Switch to dialogue entry mode ,
_ _ (i.e. draw object solely by entry in
* CTRL +Y:Redo * CTRL + SHIFT + A: Deselect all objects command and attributes box.)
* CTRL +Z: Undo - * CTRL + D: Fit view Sredefined View Angl *  F6: Render model wire frame
e CTRL + 0: Cascade windows redetined View Angles
i . To * F7: Render model smooth shaded
* CTRL + 1: Tile windows horizontally ®
* CTRL + 2: Tile windows vertically ® ®
* Alt + Double Click Left Mouse Button at points 2
on screen: Sets model projection to standard ® @
isometric projections (see diagram to the right). Loft Right
* Alt + Double Click Right Mouse Button at points
on screen: give the nine opposite projections. ® ® ®
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