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Outline - HFSS 3D Layout BGA Package Differential Pairs Workshop 

This HFSS 3D Layout workshop W01 starts with a PCB geometry and goes through 
the simulation workflow steps to simulate two differential pairs.  

1. Starting BGA geometry   hfss_layout_bga0.aedt

2. Edit stack up and verify materials hfss_layout_bga1.aedt

3. Cut out subdesign hfss_layout_bga2.aedt

4. Add solder balls and flip chip bumps hfss_layout_bga2.aedt

5. Add ports hfss_layout_bga2.aedt

6. Define Extents hfss_layout_bga2.aedt

7. Add Solution Setup and Frequency Sweep hfss_layout_bga2.aedt

8. Simulate hfss_layout_bga3.aedt

9. Plot S-parameters hfss_layout_bga4.aedt 



HFSS: Launching ANSYS Electronics Desktop 

Open HFSS and Set Options (if not already set)   

▪ A To access HFSS, click the Microsoft Start button, Select:                    
Programs > ANSYS Electromagnetic Suite > ANSYS Electronics Desktop

A new "Project1" appears under the Project Manager. 

▪ Setting Tool Options (skip this slide and two more if already done.) 
Select the menu item Tools > Options > General Options

Option settings suggested here ensure that the 
user can consistently follow the steps in the 
Workshop. 



Setting Tool > Options for HFSS 1 - Boundary and Drawing 

▪ Selected: Tools > Options > General Options

▪ Expand HFSS (by clicking on the + sign) and Select Boundary 
Assignment 
• Check all entries 

▪ Expand 3D Modeler and click Drawing
• Automatically cover closed polylines:  Checked
• Edit properties of new primitives:  Checked

Option settings suggested here ensure that the 
user can consistently follow the steps in the 
Workshop. 



Setting Tool > Options for HFSS 2 - Display History and Transparency 

▪ Expand Display
1. Click Rendering and set Default

Transparency to 0.7
2. Click History Tree and check all entries (not 

shown here)

▪ Click the OK button to close the Options dialog 
box

Option settings suggested here ensure that the 
user can consistently follow the steps in the 
Workshop. 



RXDATA3-

RXDATA3+

BGA Package Differential Pair Simulation with HFSS 3D Layout

From a BGA Package CAD geometry, this example shows you how to set up, simulate, and analyze two differential 
pairs: 

RXDATA3+, RXDATA3- and RXDATA4+,RXDATA4-



Import/Restore .aedtz Archive File with HFSS Standalone

▪ Select the menu item File > Restore Archive
1. File name: hfss_layout_bga.aedtz
2. Click the Open button
3. Project File Restore Location Dialog
• File name: hfss_layout_bga0.aedt 
•  Open project after restoring  

▪ After restoring, click the Close button to 
close the Restore Archive pop up box. 



Imported HFSS 3D Layout - hfss_layout_bga0.aedt 

Layout



Appearance

2/27/2018 The blue, on the right hand image, comes from 
clicking the first "Top" box which fills in that square solid. 

Toggle to change appearance



Start Editing the Stackup

▪ In the Ribbon, with the Layout tab selected, click of 
the Layers dialog icon to open up the Edit Layers 
dialog box. 

This dialog box is also available from Layout > Layers. 

▪ Near the top of the Edit Layers dialog box, in the box 
labeled Stackup, set units to microns
• Units: um

▪ By clicking on the symbols on the left hand side, rows 
in the stackup can be selected.  

Stackup



Editing Dielectric Fills in the Stackup

▪ In the Edit Layers dialog box…. 
▪ Correct the Dielectric Fill
• Select the row Name: TOP
• In the Dielectric Fill column: 

from the pull-down, select FR-4
• Select the row Name: VDD_C1

▪ Dielectric Fill: select FR-4
• Select the row Name: VSS_C1

▪ Dielectric Fill: select FR-4
• Select the row Name: Bottom

▪ Dielectric Fill: select AIR
• Click the Apply and Close button

Stackup



Stackup - Dielectric Fill Editing Done - hfss_layout_bga1.aedt

Save file as 
hfss_layout_bga1.ae
dt

Total height 731.52 
um

Stackup



Start Verifying Material Properties - Air

▪ To edit/verify the material definitions of the 
imported materials…

• In the Project Manager, expand the Definitions
folder and then the Materials folder

• Double-click on the material: Air
• View/Edit Material dialog

1. Material Name: Air
2. Relative Permittivity: 1.0006
3. Relative Permeability: 1.0000004

Notice that the OK button only becomes available 
after something is edited. 

▪ Click the OK button (if needed) to close the 
View/Edit Material dialog when finished. 

…continued on next page

Stackup



Verify Material Properties (Copper and FR-4)

…continue verifying material properties…in the 
Project Manager > Definitions folder > Materials
folder

▪ Double-click on the material: COPPER
• View/Edit Material dialog
1. Material Name: COPPER
2. Relative Permittivity: 1
3. Relative Permeability: 0.999991
4. Conductivity: 59590000
5. Dielectric Loss Tangent: 0
6. Press the OK button

▪ Double-click on the material: FR-4
• View/Edit Material dialog
1. Material Name: FR-4
2. Relative Permittivity: 4.5
3. Relative Permeability: 1
4. Dielectric Loss Tangent: 0.035
5. Press the OK button

Note: The OK button only becomes available after something is edited.

Stackup



Region "User" Layer for Subdesign Cutout 
In order to analyze two specific differential signal pairs, we'll cut out a portion of the overall layout 
into a subdesign that contains only the two desired differential pairs and the reference net(s).  Net 
names for the differential pair include RXDATA3+, RXDATA3-, RXDATA4+, RXDATA4-.  

To facilitate cutting out the subdesign, we'll draw a rectangle on a "user" layer, an extra                        
utility layer not used for geometry in the PCB design.  The user layer name in this design                            
is Region.  

If there is not yet present in the layers a Region layer, follow the instructions below to                                    
create one.  

▪ If the Region layer is present, skip forward and make Region the active layer. 

▪ To create a Region User Layer…(if the Region layer is NOT yet present)
• Select the menu item Layout > Layers to bring up the Edit Layers dialog box.

1. In the upper left Display area: Non-stackup layers.
2. Click on the (top?) row for the layer with name outline.
3. In the lower left Layer area, click Insert above... to open the Add Layer dialog. 

‒ Name: Region
‒ Type: User
‒ Press the OK button

4. Press the Apply and Close button to close the Edit Layers dialog box. 

outline

Layout



Set Active Layer - Region

There are two easy ways to set the active drawing layer in HFSS 3D Layout. 

▪ In the Ribbon, with the Layout tab chosen, click on the down-triangle     
next to layer names to choose a different active layer. 

▪ In the Layers window, simply click on the radio button (round space)              
next the layer name to make it active. 

Active Layer

Layers 
Dialog

View > Layers

Active Layer

Layout



Draw Rectangle on Region Layer for Subdesign Cutout

In order to create a rectangle for the cut-out…
▪ In the Ribbon, with the Layout tab highlighted, select the Draw rectangle icon.

▪ Another way to access drawing a rectangle primitive is from the top pull downs  
Draw > Primitive > Rectangle.

• The first click signifies first vertex of the rectangle. The second click is for the 
diagonally opposite vertex.

…continued…

Layout



Finished Rectangle for Subdesign Cutout

▪ Move your mouse to 
visualize the rectangle.

▪ Draw the rectangle to 
encapsulate the right-
hand half of the package 
model.

The coordinates are 
accessible in the Properties
menu with the rectangle 
highlighted.  If the initial 
freehand draw doesn't work, 
the two points 
Pt A: 0, 5 mm and 
Pt B: 5, -5 mm 
can be entered in 
Properties. 

(0 mm, 5 mm)

(5 mm, -5 
mm)

Red 
squares 
indicate 
drawn 
rectangle. 

This line is not part of 
rectangle
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Alternative Way to Draw Rectangle

• Select the menu item Draw > Primitive > Rectangle

▪ Using the coordinate entry at the bottom of the windows, enter 
the following:

1. Units: mm

2. X: 0 Press the Tab key

3. Y: 5 Press the Enter key

4. Press Tab key twice

5. Delta X: 5 Press the Tab key

6. Delta Y: -10 

7. Press the Enter key

rectangle 

Layout



Cutout Subdesign

In order to cut out the subdesign….
▪ With the rectangle selected, in the                                            

Ribbon, with the Layout tab selected,                                      
select Cutout, which brings up the                                         
Cutout Subdesign dialog box. 

▪ This cutout function can also be accessed with the 
menu item Layout > Cutout Subdesign
• Check the box for Create new <Create new parent 

HFSS 3D Layout>
• Place check in the Include column for the following 

nets:
▪ RXDATA3+, RXDATA3-, RXDATA4+, RXDATA4-, 

VDD, VSS
• Place check in the Clip at extents column for the 

following nets:
▪ VDD, VSS

• Click the OK button to close the Cutout Subdesign
dialog box. 

Layout



Cutout Subdesign

▪ A new design will be added to the project and should become the active design. 

▪ Below is a picture showing the cutout

▪ Save file as hfss_layout_bga2.aedt

Layout

Cutout design



Add BGA Solder Balls/Flip Chip Bumps to FCHIP on Subdesign

▪ For the cutout subdesign "hfss_layout_bga_cutout", access the 
Components window…                                                                                     
The Components window is available from View > Components

▪ From the Components dialog window
• Expand Other (by clicking on the + sign), expand FCHIP, click on 

FCHIP component and Right-click
▪ Click on Model..

…continued…

To create Flipchip bumps for the component, we define the Solder Ball properties to the FCHIP 
component.  A reference plane for the Flipchip bumps is automatically added to the geometry.



Add BGA Solder Balls/Flip Chip Bumps to FCHIP on Subdesign

In the Component Model dialog box…

▪ Solder Ball Properties
• Shape: Cylinder
• Diameter: 0.075mm
• Mid Diameter: 0.075mm
• Height: 0.075mm
• Material: solder

▪ Click the OK button



Add BGA Solder Balls/Flip Chip Bumps to CSP_BGA
▪ Adding BGA Solder Balls/Flipchip Bumps…
• From the Components dialog window
• Expand IO, expand CSP_BGA, click on BGA

component and right-click
▪ Click on Model ...bringing up Component Model                                      

dialog box
1. Solder Ball Properties

‒ Shape: Cylinder
‒ Diameter: 0.33mm
‒ Height: 0.33mm
‒ Material: solder

2. Click the OK button

Reference plane for the BGA Solder Balls 
is automatically added to the geometry.



Create Ports on Diff Pairs at Flip Chip Reference Plane
▪ From the Components dialog window
• Expand Other, expand FCHIP, click on FCHIP component and Right-click
• Click on Create Ports on Component...

1. Select the nets: RXDATA3+, RXDATA3-, RXDATA4+, RXDATA4-
2. Port Configuration

‒ Type: Port
3. Click OK

Flipchip 
Reference 
plane

Port
Excitations



Create Ports on Diff Pair at BGA Reference Plane

Flipchip
reference plane

Port 
Excitations

BGA reference plane

▪ From the Components dialog window
• Expand IO, expand CSP_BGA, click on BGA component and right-

click
• Click on Create Ports on Component...

1. Select the nets: RXDATA3+, RXDATA3-, RXDATA4+, RXDATA4-
2. Port Configuration

‒ Type: Port
3. Click OK



Define HFSS Extents
Using HFSS Extents, we define the computation region for HFSS.
Dielectric  Horizontal Padding and the dimensions of Airbox are defined. 
The values can be entered as absolute values (10mm) or as percentage of 
the maximum of either length or width of the dielectric-polygon. 

▪ In the Ribbon, with the Layout tab highlighted, click on the triangle by 
HFSS Extents, and select Edit…                                                                       

Another way to access the Set HFSS Model Extents dialog box is to 
Select the menu item HFSS 3D Layout > HFSS Extents.

• Dielectric
1. Horizontal Padding: 0

• Airbox
1. Horizontal Padding: 0.025
2. Vertical Padding: 0.025
3. Sync: 

• Click the OK button

▪ To visualize the HFSS extents:
• Select the menu item Layout > Draw HFSS Air Box
• Select the menu item View > Rotate

Draw HFSS Air Box

Airbox

triangle



Solution Setup

▪ Creating an HFSS Solution Setup
• In the Ribbon, with the Simulation tab highlighted, 

click on HFSS to bring up the HFSS Setup dialog box.

Another way to access HFSS Solution Setup is 
select the menu item HFSS 3D Layout > Solution 
Setup > Add HFSS Solution Setup

1. Click the General tab:
‒ Setup Name: HFSS Setup1
‒ Solution Frequency: Single
‒ Frequency: 2.5 GHz
‒ Maximum Number of Passes: 20
‒ Maximum Delta S: 0.02
‒  Save fields

2. Click the OK button

• The frequency sweep setup dialog will automatically 
appear…continued 

Solve Setup



Edit Frequency Sweep 

In the Edit Frequency Sweep dialog box…

Edit Frequency Sweep tab…
▪ Name: Sweep 1
▪  Use Q3D to solve DC point
▪ Sweep Type: Interpolating
• Type: Linear Step
• Start: 0 GHz
• End: 2.5 GHz
• Step: 0.01 GHz

▪ Click on the Interpolation tab…
• Relative error: 0.5%

▪ Click on Advanced Options button to open up the Interpolating 
Sweep Advanced Options dialog box…continued

Solve Setup



Frequency Sweep - Interpolating Sweep Advanced Options 

In the Interpolating Sweep Advanced Options  dialog box…

▪  Enforce causality (DC point required)
▪  Enforce passivity

▪ Press the OK button to close Interpolating Sweep Advance Options
dialog box. 

▪ Press the OK button to close Edit Frequency Sweep dialog box. 

Solve Setup



HPC Setup
Setting up High Performance Computing (HPC)…

▪ Select the menu item Tools > Options > HPC and Analysis Options

• Design Type: HFSS 3D Layout Design

• Select the Active Configuration: Local 

• Click the Edit button

• Analysis Configuration Dialog

1. Check the option for Use Automatic Settings

2. Click the Machines tab

‒ Name: localhost

‒ Cores: 4

‒ RAM Limit (%): 90

‒ Click the OK button

3. Click the OK button

Note:  The ANSYS training computers are typically configured with a single quad 
core processor.  The configuration shown here will use 4 cores for multi-
threading.  



Save, Validate, and Analyze HFSS Project - hfss_layout_bga3.aedt

▪ Click the Validate green check mark in the ribbon (with Simulation chosen) 
to validate the project.  

▪ Select File > Save As and save project renaming file as: 
hfss_layout_bga3.aedt

Keep all HFSS workshop simulation files; future workshops may continue 
with these files. 

▪ Click on Analyze All in the ribbon to start the HFSS simulation.  

The Validation Check and Analyze All operations are also available from the
HFSS pull-down at the top of the graphical user interface (GUI).  

▪ Save hfss_layout_bga3.aedt when the simulation finishes.  

Break time?  This simulation might take a few minutes.

Click on Show Messages and Show Progress in the bottom right of the GUI in 
order to see the simulation progress.



Matrix Data in Solution Data

▪ In the Ribbon, with the Results tab highlighted, select 
Solution Data, which brings up the Solutions dialog box.  

This Solutions dialog box is also available by right-clicking 
in the Project Manager, under Analysis, on HFSS Setup 1
and choosing Matrix Data. 

And..

…from the top pull down menus 
HFSS 3D Layout > Results > Matrix 
Data

▪ One can click on the Convergence 
tab, shown in next slide

▪ Press the Close button when you 
are finished.



Convergence Plot in Solution Data

▪ In the Solutions dialog box, click on the Convergence tab.  

This Solutions dialog box is also available by right-clicking in the Project Manager, under Analysis, on HFSS Setup 1
and choosing Convergence. 

And..

…from the top pull down menus HFSS 3D 
Layout > Results > Matrix Data or Profile… 
and then click on the Convergence tab. 

• The default view is for convergence is Table. 
Select the Plot radio button to view a 
graphical representations of the 
convergence data

• Press the Close button when you are 
finished.



Select Differential Pairs
Creating Differential Pairs - Step 1

▪ In the Project Manager, under Excitations, right-click                                                   
and select Differential Pairs…

▪ This Differential Pairs dialog box is also available from the                                             
top pull-down menus: HFSS 3D Layout > Differential Pairs

▪ Using the left mouse button, click and drag BGA RXDATA3                              
signals to match the Positive and Negative headings and                             
each other as shown here on the right.

▪ Using Ctrl-click or even Shift-click for vertical selection, highlight both 
BGA RXDATA3 signals.  This makes the Add Pairs >> button active. 

▪ Click on the Add Pairs >> button. …continued….

Top row arranged…

Top row moved with Add Pairs >> 

Other rows above not yet arranged for adding pairs

Post
Processing



Finish Adding Differential Pairs
Creating Differential Pairs - Step 2

▪ In the Differential Pairs… dialog box, continue adding differential pairs.  
▪ Click OK when finished. 

− Using mouse left button, click and drag 
signals on the left side to match the 
Positive and Negative headings and each 
other as shown here on the right.

− Using Ctrl-click or even Shift-click for 
vertical selection, highlight all the 8 
signals.  This makes the Add Pairs >> 
button active. 

− Click on the Add Pairs >> button. 

Post
Processing



Viewing Results - Starting 2D Report for Differential Pairs

Creating Reports…
▪ From the Ribbon, with the Results tab selected, click on the 

down triangle by Standard Report and select 2D.  

The Report dialog box can also be accessed from the Project
Manager, under Results, by right-clicking on Results and 
selecting Create Standard Report > Rectangular Plot

Or

…from the top pull-down menus…select the menu item HFSS 
3D Layout > Results > Create Standard Report> Rectangular 
Plot

▪ In the Report dialog box…
• Solution: HFSS Setup1:Sweep 1
• Domain: Sweep
• Show: Differential pairs

1. Category: S Parameter
…continued…



Viewing Results - Transmission Differential Pair S-Parameters

In the Report dialog we want to pick out the 
transmission pairs.  We can refer to our 
differential pair definitions as needed…

▪ Quantity: transmission terms 
S(Diff1,Diff3), and S(Diff2,Diff4)

▪ Function: dB
▪ Click New Report button and then Close.



Viewing Differential Pair Transmission S-Parameter Plot



Viewing Results - Reflection Differential Pair S-Parameters

▪ Create a second Report…

• Solution: HFSS Setup1:Sweep 1
• Domain: Sweep
• Show: Differential pairs

1. Category: S Parameter
2. Quantity: Click the pull-down and select only 

self reflection terms S(Diff1,Diff1), 
S(Diff2,Diff2), S(Diff3,Diff3), S(Diff4,Diff4)

3. Function: dB
4. Click New Report button and then Close.



View Results in Network Data Explorer

▪ Explore results using Network Data 
Explorer
For terminal data with large port-count, 
Network Data Explorer provides an 
efficient and dynamic mechanism for 
investigating results

• In the Project tree, under Analysis, 
expand to show Sweep, then right-
click on the Sweep1 entry and select 
Results > Network Data Explorer

• Set Format: dB

• Check Select all or choose signals 
individually.  

• Save hfss_layout_bga4.aedt when 
the simulation finishes




