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Introduction to Icepak in AEDT

Release 2020 R1

Module 1 – Workshop 1: Model 
Building in AEDT Icepak
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Objectives

• Build a simple model in AEDT Icepak
‐ Create heat sinks and fans

‐ Assign boundary conditions

• Generate and review the mesh
‐ Use the automatic slider-bar mesher to generate the 

mesh

‐ Review the mesh for resolution and quality

• Setup the model

• Analyze the simulation

• Use post processing tools to analyze the solution
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Model Overview

• The model has the following 
generic components
‐ Intake fans

‐ Outlet grille

‐ Board

‐ Heatsink

‐ GPU

‐ DDR memory

‐ Flash memory

• A STEP file will be imported for 
the model and the heatsink and 
fans will be added

Cabinet 
(Computational 

Domain)

AGP

Outlet Grille

DDR Memory Heatsink

PCB

Large Flash and 
Small Flash Memory

2D Intake Fans

Bridge



©2020 ANSYS, Inc. Unauthorized use, distribution, or duplication is prohibited.4

Starting AEDT Icepak

• Create a new Icepak project in AEDT as 
follows:
‐ Launch ANSYS Electronics Desktop (AEDT) 

from Windows start menu or the desktop 
shortcut
• Start → All Programs → ANSYS EM Suite 2020 R1 → 

ANSYS Electronics Desktop 2020 R1

‐ Insert a new Icepak project from the ribbon 
or the dropdown menu
• Project → Insert Icepak Design

• Use Workshop 01 as the project name

• You can rename Icepak Design to 
Electronics Chassis
‐ Right click on IcepakDesign1 and click 

Rename

Select Icepak project under the Desktop tab

Change the project name and 
design name
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ANSYS Electronics Desktop Interface

Menu Bar

Ribbon Tab

Project 
Manager

Design Area

Ribbon Area

Properties 
Window

Message 
Manager

Progress 
Window
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Set Default Units for Icepak Project

• Set Model Units panel can also be accessed from Modeler → Units

Set the units to mm

Navigate to Draw tab and click on Units
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Import the Geometry and Setup Domain

• Click on Modeler in the dropdown menu and click Import

• Select the file Workshop_01.step from the workshop directory, confirm that ‘Create 
groups for assembly’ is unchecked and click on ‘Open’

• To switch between wireframe and smooth shade mode, press F6 (wireframe) and F7 
(smooth shade)

Uncheck Create Groups for Sub Assemblies
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Group and Ungroup Objects

• The 3D Modeler allows you to group objects in the History tree 

• Groups permit you to bring in MCAD assemblies and sub-assemblies as groups

• Ungroup the group named Workshop_01 to bring all objects under the Solids node 

• To ungroup, right-click on Workshop_01 → Group → Ungroup
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Solution Procedure in AEDT Icepak

• Domain setup and model preparation includes all steps that are followed to setup the geometry 
such as creating fans, heat sinks, etc. 

• Boundary condition assignment includes flow boundaries such as openings, grilles, etc. and heat
sources such as network thermal resistance, power, etc.

• Material properties such as density, specific heat, thermal conductivity, viscosity, etc. tells the solver 
how much heat is retained and dissipated out of an object 

• Meshing is a critical step as all the governing equations are solved in the computational cells 
created during meshing process

• Solver setup tells the solver how long the problem should run and under what settings
• Once the solution is obtained the post processing step helps the user to make sense of the 

simulation by analyzing the results

Domain Setup 
and Model 
Preparation

Boundary 
Conditions, 

Heat Sources, 
Materials 

Assignment

Meshing Solver Setup Post 
processing

9
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Domain Setup

• Right-click on Solids and select Expand All
• Select CreateRegion under air 
• In the Properties panel, input the padding values shown 

below
• Notice that some inputs use values by Absolute Position, 

and others by Absolute Offset.

2 31
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Create Intake Fans

Fans will be added by creating relative 
coordinate systems (CS) and placing the fan 
object on the Relative CS
• Choose the Global Coordinate System from 

the Coordinate Systems node 
• Click on Offset Origin Icon in the Draw ribbon.
• Create relative coordinate system by 

offsetting origin at -25, -20, 10
• (Alternatively use Modeler → Coordinate 

System → Create → Relative CS →  Offset)
• Press F4 and enter the values for the origin of 

the relative coordinate system as shown
• Rename the relative coordinate as 

‘Fan_Coord)

Note: Deleting the relative coordinate system will delete the associated object (in this case, fan)

1

2

3

• Toggle between point and 
dialog entry mode by pressing 
F3/F4

• Point entry mode allows you to 
select a point in the Graphics 
window

• Dialog entry mode (F4, shown 
on left) allows you to enter the 
coordinate values 

Name can be 
changed from 
the Properties 

panel
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Create Intake Fans

• In the Project Manager, under Electronics Chassis, right click 
on 3D components and choose Create → Fan…

• Enter ‘Fan’ for name, click Next and Enter the details as 
shown and click Finish

• The process will create Fan1 in the Model Tree

1

2 3

YZ Plane
Radius = 10 mm

4Click Next

Fixed Volumetric
10 CFM
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Copy the Intake Fans

• In the Model tree, select Fan1
• In the Draw tab, select Duplicate along 

line (see image for icon) 
• Use the Dialog entry mode (F4) to enter 

the values
• Translate the fan by -60 mm in the y-

direction
• Total Number = 2
• Click OK and it will create Fan2

Note: This method will change the properties of any 
duplicates/copies of the fan. For example, if you created a second 
fan by copying the first fan, then changing the flow rate for first 
fan will change the flow rate for the second fan as well. 

Workaround: Create two distinct fans

1

2
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Create Heat Sink

• Select ‘Global’ under coordinate system, 
right-click on 3D Components and choose 
Create → Heatsink

• Give the name ‘ Heatsink’ and Enter the 
values for heatsink dimensions and 
properties as shown

• Click Next and retain the defaults for 
materials and click Finish

Flow Direction is 
based on current 

working coordinate 
system.
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Move the Heatsink

• Select the Heatsink1 and from the 
Draw tab, select Move icon

• Hover the mouse pointer at the 
bottom face of the heat sink until 
the pointer turns into a circle. Click 
to select the center of the face

• Next, hover the mouse pointer 
over the top face of the AGP to 
search for the face center. When 
the pointer turns into a circle, click 
to select the center of the face

• The heat sink will be moved to the 
new location

Move objects 
icon in Draw 
tab

Use F3 / F4 to toggle between point and dialog entry modes.

Note: The heatsink can 
also be aligned to AGP 

using any edge at the base 
of the heatsink as the 

anchor point
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Assign Boundary Conditions – Flow Boundary

• Click on Region under Solids → 
air

• In the Properties window, change 
the name to Domain

• Next, press F to change to face 
selection mode

• Select the max X face of the 
domain

• Right click and select Assign 
Thermal → Grille…

• Enter MaxX_Grille for name, use 
0.8 for Free Area Ratio and click 
OK to accept other default 
settings
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Assign Boundary Conditions – Wall Boundary

• Select the lateral sides of the 
domain, i.e., minY, maxY, minZ
and maxZ

• Right click → Assign Thermal → 
Wall → Stationary

• Enter SideWalls as name in the 
panel

• Select Heat Transfer Coefficient 
under Thermal Specification 

• Enter a value of 10 W/(m2K)

• Click Finish

Boundary Conditions appear under 
the Thermal node in Project Manager

Note: Spaces are not allowed in names
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Hiding Objects

• To hide objects in the graphics area, select 
the objects in the model tree

• You can select multiple objects at once by 
pressing CTRL key and clicking on the 
respective object names in the tree

• Right-click → View → Hide in Active View

• Alternatively, you select a body in the 
graphics area by pressing O and then 
clicking on the body

• Next, press CTRL+H to hide the body

• Hide the ‘Domain’ under ‘air’ in the model
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Basics of 2R Thermal Network

• Package objects ‘Bridge’ and ‘AGP’ will be 
modeled as 2R Thermal Network

• 2R Network Basics:
‐ The bottom face (coincident with the board) of the 

package is board side and the upper face is case side

‐ The power is specified at the Internal node

‐ Rjb is the thermal resistance from the internal junction 
to board

‐ Rjc is the thermal resistance from internal junction to 
case

Board

Rjc

Rjb

Internal 
node

Board

Board side link - Rjb

Case side link - Rjc
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Creating 2 R Thermal Network for Bridge

• Switch to face selection mode by 
pressing F

• Select the top face of ‘Bridge’

• Press B to switch selection to the 
back face

• Press CTRL and then select the top 
face of the Bridge again

• The two faces of Bridge are now 
selected as shown in the figure

With the faces selected, 
right click on the 

Display area and select 
Assign Thermal and 
then select Network
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Creating 2 R Thermal Network for Bridge

• Assigning Network will open ‘ Network 
Thermal Model’ Window.

• Review the Face nodes, Internal node and 
Links diagram.

• Name the Network as ‘ 
Bridge_2R_Network’ 

• Rename the end face nodes as ‘Case’ and 
‘Board’ by double-clicking on the respective 
node names. ( Double check the selected 
face in GUI to confirm board side and case 
side faces)

• Rename the Internal node as ‘Junction’, and 
‘Link1’ and ‘Link2’ as Rjc and Rjb
respectively.

• To edit the resistances and power values, 
double click on the symbols which will pop 
up the edit panel. ( Explained on the next 
slide.)

Click here on the 
name to rename

Click here to input 
power and resistance 
values.
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Creating 2 R Thermal Network for Bridge

• Use the following entries for Rjb = 3.5 C/W, Rjc = 1.5 C/W and internal node power as 
2.5 W

Junction to board thermal resistance Junction to case thermal resistance

Junction power – Bridge 



©2020 ANSYS, Inc. Unauthorized use, distribution, or duplication is prohibited.23

Creating 2 R Thermal Network for AGP

• Repeat the steps discussed for AGP. You can hide the ‘Heatsink’ object to select the faces.

• Use ‘AGP_2R_Network’ for the network name.

• Enter the values for Rjb = 4 C/W, Rjc = 1.2 C/W, and junction node Power = 54 W as below.

Junction to board thermal 
resistance Junction to case thermal resistance

Junction power – Bridge 
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Add Heat Sources – Power Assignment

• Select Large_Flash from the model tree
• Right click → Assign Thermal → Block…
• Enter the Name as Large_Flash and use value of 

1.25 W for total power
• Repeat the above steps for Small_Flash and 

DDRs and use the powers listed below
• Tip: Multiple objects can be selected to create a 

single thermal block object.  The same power 
input in the block panel is applied to all objects.

• Select all four DDRs and input 1.125W as the 
Total Power.  Each DDR will have 1.125W for a 
total of 4.5W.

Small Flash – 0.5 W
Large Flash – 1.25 W

DDRs – 1.125 W
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Assign Material Properties – Board 

• Right click on Board in the Model Tree 
and select Assign Material…

• In the Select Definition panel click Add 
Material to create a new custom material

• Enter the values shown in the figure

1

2

Click OK to complete

Click OK to complete

Select Anisotropic Material Type
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Assign Material Properties to Components

• Select the DDR components, AGP, 
BRIDGE, Large Flash and Small Flash 
from the Model tree

• You can select multiple objects at 
once by pressing the CTRL key and 
selecting the object names in the 
model tree

• Right click on the components in 
Model Tree and select Assign 
Material…

• You can search for a material by 
name or by property

• Search for the Ceramic_material and 
click OK to assign the material and 
close the Select Definition panel

1

2

3



©2020 ANSYS, Inc. Unauthorized use, distribution, or duplication is prohibited.27

Assign Material Properties – Contd.

• Select all objects in the Model tree

• In the Properties box of the object, select 
Steel-oxidized-surface for surface material

• Network blocks should have Solve Inside 
turned off
‐ Make sure ‘Solve Inside’ option is turned off for both 

AGP and Bridge objects.

Solve Inside should be turned off for 
network objects
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Changing Object Priority

• Right click on Model under 
the Project Manager and 
select Object Priority…

• Select the DDR objects from 
the model tree and then click 
on Add Priority List in the 
Object Priority panel 

• Next select AGP and Bridge 
and then click Add Priority List 
in the Object Priority panel 

• Click OK to close the panel
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Summary of Problem Setup

Object Power (W) Material 
Thermal 

Conductivity 
(W/(m.K))

DDR1 1.125
Ceramic 
Material 15

DDR2 1.125
Ceramic 
Material 15

DDR3 1.125
Ceramic 
Material 15

DDR4 1.125
Ceramic 
Material 15

Large Flash 1.25
Ceramic 
Material 15

Small Flash 0.5
Ceramic 
Material 15

Board 0
Custom 
Board

(35.143, 35.143, 
0.395)

Fan Flow Rate = 10 CFM each

Object Power (W) Rjb (C/W) Rjc (C/W)

AGP 54 4 1.2

Bridge 2.5 3.5 1.5
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Solver Settings

• Click on Setup in the Simulation tab

• Enter ForcedConvection_RadOff as simulation 
name

• Set the maximum number of iterations to 500

• Use Enhanced Realizable Two Equation as 
turbulence model

• Click Radiation Off

• Check the box for Flow and Energy Equations 
Sequentially (With this option 400 of 500 
iteration will be used for flow iteration and 
rest will be used for Energy iteration)
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Solver Settings

Convergence Criteria:
Flow = 1e-4
Energy = 1e-12

Recommended Settings for Sequential 
Solution of Flow and Energy
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Solver Settings

• Finally check for any errors in the model

• Under the Simulation tab, click on Validate

• Click Close to close the validation check panel
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Workflow for Mesh Generation and Viewing

Global Mesh 
Settings

• Slider bar 
(automated)

• Advanced 
(manual)

Generate Mesh

• Mesh 
generation 
step

Mesh Viewer

• View mesh 
for quality

• View mesh 
over a plane 
or on a 
selected 
object

Note: Only slider bar mesher will be used in this workshop
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Meshing the Model

• Click on Global Mesh Settings under Simulation tab

• Use the Fine setting in the slider bar for mesh

• Click OK

• Click Generate Mesh



©2020 ANSYS, Inc. Unauthorized use, distribution, or duplication is prohibited.35

Viewing the Mesh

• Click on Mesh Viewer

• Use the cut plane option on a plane or Geometry/Boundary 
selection option to view the mesh on objects

Cut plane Geometry Selection
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Viewing the Mesh

Mesh 
count

X plane 
through 
center

Y plane 
through 
center

Z plane 
through 
centerSlider to move cut plane 

Wire or shaded cut plane
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Mesh Quality

Min and Max values for 
face alignment and 
skewness are shown 
here

• For a good quality mesh:
‐ Min. Face Alignment > 0.05

‐ Min. Skewness > 0.02

• It is recommended to        
check mesh quality 
before running a 
simulation
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Mesh Quality

• Modify the histogram range to locate the cells 
between desired range

• Change the number of bars to 1

• Click on histogram to highlight the cells in the 
graphics area

Left click 
mouse 
here

Modify 
range 
here

Tip - Can be used to locate bad cells:
Min value = 0
Max Value:

0.05 (Face alignment)
0.02 (Skewness)
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Create Monitor Points

• Right click on Large_Flash in the 
model tree and click Assign 
Monitor → Point…

• Enter the name and click on 
Temperature

• Control select all the DDR object 
in the model tree and right click 
Assign Monitor → Point…

• Enter the name and click on 
Temperature
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Analyze the Setup

• Right click on the setup ForcedConvection_RadOff
under the Analysis node in Project Manager

• Click on Analyze

• Right click on the ForcedConvection_RadOff and click 
Monitor.

• Residual and Monitor Tab should give information on 
convergence
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Post Processing

• Click on the Results tab and select Fields Summary

• Select Object for Entity Type and Volume for Geometry 
Type

• Select Board, DDR objects, Large Flash, and Small Flash 
from the object list

• Select Temperature under Quantity list

• Click on Add and select Add as Multiple Calculations
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Post Processing

Results can be exported as a 
CSV file
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Reporting Network Temperatures

• In the Setup Calculation panel, select Boundary for Entity Type and Surface for Geometry Type
• In the Entity list, select AGP_2R_Network and Bridge_2R_Network
• Select Temperature in Quantity list
• Click on Add and select Add as Multiple Calculations
• Note the Network Junction temperatures for AGP and Bridge
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Post Processing

• Select the all the model components from the model tree 

• To select the heat sink, expand the Heat sink node and 
select all the solids 

• Right click and select Plot Fields →  Temperature → 
Temperature 

Click on Plot 
on surface 
only
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Post Processing: Temperature contour on the component surface

Double 
click on 
color 
legend

Double click on color legend to get the 
property window for legend

Change spectrum of colors 
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Post Processing

• Expand the planes node and select Fan_Coord:XY
• Right click in the Graphics area and select Plot Fields → Velocity → Velocity
• Click Done on the Plot Fields panel to accept the defaults
• Drag the legends to show temperature and velocity legends simultaneously 

The plots appear 
under the Field 
Overlays node in 
the Project 
Manager
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Save the Model *.aedtz File

• The *.aedtz file is useful for sharing a model with 
colleagues and Icepak Technical Support

• The *.aedtz file compresses the model and associated 
boundary conditions, material properties and mesh 
settings

• Select Results/solution files to include completed 
solutions

• Additional files can be included in the archive, *.pdf, 
*.pptx, etc.

• Click OK
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Ideal Workshop Outcome

• You should be able to:
‐ Build Icepak objects like fans and heatsinks in AEDT Icepak

‐ Assign boundary conditions

‐ Assign material properties

‐ Generate a mesh using the Slider Bar mesher

‐ Setup physics and solver settings

‐ Run the simulation and post process the solution

‐ Save a project and archive it for backup or sharing 
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Appendix – Additional Exercise

• AEDT is able to import packed Classic Icepak model (*.tzr) except certain features which 
are not yet available and should provide similar mesh and results

• To import the tzr file ( Classic-WS1.tzr available in workshop folder) into AEDT Icepak:
‐ simply drag and drop the tzr file into AEDT. You don’t have to open an Icepak design type first. AEDT 

automatically inserts an Icepak design type

• Review the imported model
‐ Check for any messages

‐ Objects imported successfully should  include – all blocks, 2D fans, and boundaries such as walls and 
grilles

‐ Objects not imported –heat sink

• Objects that are not imported can be recreated following the steps in the main workshop.

• Physics settings should also be imported successfully

• Solve and Post process following the steps in the main workshop.



End of presentation


